need assistance reconfiguring new build of KDE

Christian Müller cmueller at
Sun Apr 13 22:16:15 BST 2003

Am Sonntag, 13. April 2003 20:01 schrieb Dan Shakhmundes:
> Hi everyone,
> I have been running Gentoo Linux, with KDE 3.0.3 through VNC.  
> 1) I still get the KDE 3.0 splash screen on start-up.
> So, I know my config is totally screwed.  It looks like it's trying to find
> things in the wrong directories.  I've tried looking through all sorts of
> documentation but can't find any solutions.  One after the other, I've
> tried emerge rsync + emerge system, updating vnc, and then xfree.  After
> each of those updates, I still had the same problems.  Please help me, I
> really miss my KDE over VNC :(
> Dan S.

Gentoo sometimes keeps more than one version of an installed 
package around (in so-called different "slots").  
Normally that's a feature, not a bug :)
I guess that's what happened to you. 
If you don't need KDE 3.0.3 any more then unmerge it.  That way you can be sure 
you don't have any old stuff around.  

emerge unmerge kde-base/kde-3.0.3

After that take a look at /etc/env.d/ and check whether all the 
references to kde3 have disappeared. 
Then do an env-update (again). 

If you still got broken entries you might try to fix them manually or 
create a symlink: 

ln -s /usr/kde/3.1 /usr/kde/3

In your home dir, make sure that you only have *one* directory tree 
for your KDE config files.  It may be that you have to manually move
around files if you want to keep your configuration. 
For example, I have a directory .kde3.1 and, 
out of paranoia, symlinked .kde, .kde2 and .kde3 to it.
Not sure if this last procedure is recommended (not very clean)
but it works for me...

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: signature
URL: <>
-------------- next part --------------
This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list