Peter Gostelow gostelow at
Thu Apr 10 01:17:52 BST 2003

On Saturday 05 April 2003 12:00, Michael Chidley wrote:
> How can i get KPPP to work without having to type in the root password for
> every user except root. I have tried to follow the instructions within KPPP
> manual but it still doesn`t work.

Not sure I follow, but verify under Setup|Accounts|Edit that 'store password' 
is checked. This will remember the (Internet)  password so users don't have 
to enter (or know) it.

If you need root access to run kppp, then perhaps your /dev/ttySx and/or file 
permissions are too tight.

On my system, ppp puts a lock at /var/lock/LCK..ttyS0, so you should allow rwx 
for /var/lock. To test, give full permissions (777) to both ttyS0 and 
/var/lock. If that works, disable world (770) and put users in the same group 
as ttyS0 and /var/lock.

The scripts ppp-on and ppp-off (/etc/ppp/ppp-scripts) should work and do the 
same thing as kppp. If they don't work for users, it's unlikely kppp will. 
The directories on your system are probably different to mine, but the 
device, lock, and script names should be the same.

If you suspect it's PAM, disable it and see if root access is still needed.

hope that helps.

> I have KDE 3.1 running on Redhat 8.0.
> I think the problem is with PAM authorising but I can`t get my head round
> it.
> Thanks
> Mike
This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list