DCOP Problem with 2 KDE3.0 users

Dave Anderson r-n-d at pacbell.net
Sun Aug 4 20:57:59 BST 2002

Still no response on this... Am I posting to the wrong list?


Dave Anderson wrote:
> I have KDE 3.0 running on Solaris 8.
> I have spent considerable time trying to debug this problem:
> I have set up a user which I use to test kde3; kdetest is the username. 
> I also have users set up to run CDE & KDE2. Everything was fine up to 
> this point; I could choose any of these users and get the appropriate 
> window system to come up as the default.
> Now, I added some users for my girlfriend to use(she doesn't have time 
> to learn the ins & outs, so I'm trying to make it easy for her) I added 
> robin(default WM=CDE), robink2(default WM=KDE2) and robink3(default 
> WM=KDE3). This way she can test her web development in Netscape/CDE, 
> Konquerer 1.98/KDE2, and Konquerer3/KDE3 without having to know a lot 
> about how to switch things around. So far so good....
> Here is the problem:
> When I log in as kdetest, I get in fine(though I would love to strangle 
> kpersonalizer... I'm sick of it and don't know how to make it go away 
> for good.). When I log out then log in as robink3, I get dcop not 
> running errors, then kpersonalizer, then more dcop errors, then I get 
> kicked back to dtlogin.
> I have checked, and when this happens the $HOME/.DCOP* files are not 
> getting created. (the dcop errors indicate that these files can't be 
> opened)
> If I reboot, then log in as robink3, KDE starts fine; if I then log out 
> and log in as kdetest, the same thing as above happens. I took this to 
> be proof that it is not user-specific. Anyway, I copied .profile and 
> .dtprofile to robink3 from kdetest.
> Other symptoms/things I've tried:
> Permissions on $HOME in either case make no difference; I tried 755, 
> 775, 777 on both directories and get the same results.
> Interestingly, if I reboot, do "ps -ef > file1" from a telnet window, 
> log in via dtlogin as one user, then log out and do "ps -ef > file2" 
> from the telnet window, I see three additional processes running: 
> rquotad, rpc.ttdbserverd, and rpc.rstatd. I tried killing these prior to 
> logging in as the second user, but I get the same results.
> Also, if I am kicked back to the dtlogin window after getting the dcop 
> errors, and I attempt to do a command-line login, the "login" prompt 
> appears as follows(no quotes): "^[[250z"  I try to log in, and it fails. 
> Then I get the expected "login:" prompt, and it works. Strange, eh?
> I have considered moving to a newer version of KDE but there is such a 
> huge amount of effort involved(recompiling from source, since there are 
> no Solaris binaries available) that I want to wait until KDE3.1 is 
> released(not the Alpha).
> If anyone can point me in the right direction to troubleshoot this 
> problem I would really appreciate it...
> Thanks & Regards,
> Dave Anderson

This message is from the kde mailing list.
Account management:  http://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list