Is it possible to use craft on Windows 8.1 (or 7)?

Hannah von Reth hannah at von-reth.de
Tue Dec 31 10:02:06 GMT 2019


Hi,

I can investigate but if it's just a vm how about upgrading.
Regarding Windows 7 it's eol and we cant practically support it.
To rebuild kshimgen  call craft -i --no-cache kshimgen and then reinstall cmake etc.

After a longer break without updating the craft root I'd also recommend to start fresh.

If it's a dependency issue you could investigate by using dependenciesgui on a generated Shim wich is installed by the dependencies blueprint.

Cheers,
Hannah
Sent from my iPhone

> On 31. Dec 2019, at 09:48, Thomas Friedrichsmeier <thomas.friedrichsmeier at ruhr-uni-bochum.de> wrote:
> 
> ´╗┐Hi!
> 
> Trying to update an existing MinGW64 craftroot on a Windows 8.1 VM, I
> was starting to see messages "cmake.exe stopped working" and
> "python3.exe stopped working". These persisted after trying some older
> cmake targets. I wiped my craftroot and started fresh, only to get the
> same errors, soon after. I tried again two or three weeks later, with
> the same result.
> 
> I *suspect* this may have something to do with kshimgen, and I guess it
> *may* be worth a try to compile that from source (rather than getting
> it from the build cache).
> 
> However, experimentation is slow (on this VM, in particular), and the
> outcome is uncertain. So this is hoping that somebody with more
> experience can confirm my suspicions, or point me into a better
> direction, instead (or tell me that my efforts are futile in the first
> place).
> 
> Thanks!
> Thomas


More information about the Kde-windows mailing list