Recent KAuth build failure in Craft on Mac

Robert Lancaster rlancaste at
Thu Feb 2 05:48:31 UTC 2017

Hi, this is Rob Lancaster.  I help out with KStars coding.  I mainly have been porting it to mac with several other people.  We have been using Craft/emerge for building it for deployment which has worked very well overall for several months (except for several problems that Hannah von Reth has helped us with).  But just the other day, a build error showed up that had not happened before.  KAuth failed to build, which is of course a dependency, causing our whole build to fail. 
I don't have GLIBC on my system of course and this appears to be the source of the error.  It looks like there is a typo in the code that checks for GLIBC that I pasted below.  This ifndef logic appears to be backwards.

I tried posting on the IRC, but I thought I would try this too.  I am not sure the best way to contact people about the problem. I am also attaching a log file that I found in the craft build folder for kauth.

Thank you for your help,


CheckSymbolExists.c:8:19: error: use of undeclared identifier '__GLIBC__’ 

#include <stdlib.h>

int main(int argc, char** argv)
#ifndef __GLIBC__
  return ((int*)(&__GLIBC__))[argc];
  return 0;

-------------- next part --------------
A non-text attachment was scrubbed...
Name: CMakeError.log
Type: application/octet-stream
Size: 1441 bytes
Desc: not available
URL: <>

More information about the Kde-windows mailing list