Patch is not working

Jarosław Staniek js at
Tue Jun 6 13:38:08 CEST 2006

Porfirio Ribeiro said the following, On 2006-06-06 13:23:

> I was trying to compile kdelibs on windows but i am stuck on patch :(
> I have tried diferent versions of it but it always give me this:
> E:\Kde>patch -p0 < 
> E:\Kde\Setups\qt-copy-patches\0112-ksyntaxhighlighter-rehighlight-document.diff
> patching file `src/gui/text/qsyntaxhighlighter.cpp'
> Assertion failed: hunk, file patch.c, line 321
> This application has requested the Runtime to terminate it in an unusual 
> way.
> Please contact the application's support team for more information.
> E:\Kde>

Have you tried to use bash? It comes with Cygwin and 'patch' coming with it. I 
use that without problems all the time. Maybe patches only work well with 
standard unix "/" characters, not MS DOS "\".

regards / pozdrawiam,
  Jaroslaw Staniek / OpenOffice Polska

Sponsored by OpenOffice Polska to work on
* Kexi & KOffice: |
* KDE3 & KDE4 Libraries For Developing MS Windows Applications:
See also:
* Kexi For MS Windows:
* Kexi Support:

More information about the Kde-windows mailing list