Fwd: Re: Icon usability issue

James Richard Tyrer tyrerj at acm.org
Fri Jun 15 23:29:10 CEST 2007


Ellen Reitmayr wrote:
> One solution would be creating another pair of find-something icons.

Actually, we could simply rotate them 90 degrees. :-)

> Currently the find next-prev actions shows arrows point up/down  
> because we thought it was ok when looking for a string inside a text.  
> In most cases you'll find next occurrence of that string some rows  
> below.

I thought that having separate icons for find-previous and find-next was 
a good idea.  Currently, we use "next" and "previous" for that.

> But I also see that the fact the next occurence appear up or down is  
> just a case. In fact next occurence can also be in the same row, so  
> in that case arrows pointing to left and right make sense.
> 
> Another situation when up/down arrows are better than left/right  
> happen in Kmail. Current version has "find next unread message". The  
> messages are shown as a list.

I think that the arrows that point up, down, right, and left should be 
used only for sequential actions.  Non-sequential actions such as FNUM 
should use a different icon.  Currently, KDE3 has the icons: "next" and 
"previous" which KMail is using for this action.  CrystalSVG uses the 
right and left paradigm for this.  KDEClassic had what were better icons 
except that they were too complex and you couldn't see them in the 
smaller sizes.

> I think Kmail is using a wrong usage of icons. In fact you are not  
> finding next occurance of something, but you are jumping to next  
> unread message. Probably kmail action should need another action  
> called show-next-unread (or something like that).

Are you referring to KMail3 or KMail4?  IMHO, KMail3 is using the 
correct icons: "next" & "previous".  The CrystalSVG icons may not be the 
best.  I made them as an interim solution to the problem.

> My solution:
> 
> find-next find-prev should be used for string based search only (as  
> in a text editor, web page, or file search)
> "next" should have an arrow pointing down.
> "prev" should have an arrow pointing up.

Yes, this is what we have: "find next" & "find previous" are up and down 
Seems OK, but the code to switch them for RtL text needs to be removed.

> kmail, need a different action icon that actually doesn't exist yet.

KMail3 is using "next & "previous".  These icons have not yet been made 
in Oxygen.  Well actually it isn't that simple.  We have icons with 
those names but I think that they should be called "go-forward" & 
"go-back" and be replaced by icons that really reflect the idea of next 
& previous.

This code:

KGuiItem back( BidiMode useBidi )
{
   QString icon = ( useBidi == UseRTL && QApplication::isRightToLeft() )
                  ? "go-next" : "go-previous";
   return KGuiItem( i18nc( "go back", "&Back" ), icon,
                    i18n( "Go back one step" ) );
}

KGuiItem forward( BidiMode useBidi )
{
   QString icon = ( useBidi == UseRTL && QApplication::isRightToLeft() )
                  ? "go-previous" : "go-next";
   return KGuiItem( i18nc( "go forward", "&Forward" ), icon,
                    i18n( "Go forward one step" ) );
}

has a problem.  It seems to have merged the ideas of back/forward and 
previous/next.  This is not correct.  The KSA back should use an icon 
called: "go-back" and the KSA forward should use an icon called "forward"

IIRC, this whole thing got throughly messed up in KDE3 so now is the 
time to get it right for KDE4 before too many applications are using the 
wrong KSAs and we have to resort to a kludge like I did with KDE3.

KDE3 has KSAs for "previous" & "next" but they were not used properly. 
I don't know if we need KSAs previous & next.  The reason I say that is 
that it is highly probably that an app will change both the menu text 
and the tooltip text for them.

> Right-to-left languages: the actions doesn't have to exchanged.  
> that's way there's won't be any problem.

Probably OK, unless other themes use the left/right paradigm.  The 
ultimate solution would be to put a message (e.g. "<-- RtL --">) in all 
icons that needed to be reversed for RtL.

-- 
JRT


More information about the Kde-usability-devel mailing list