[kde-solaris] [kde-discuss] KDE 4.1.4 IPS packages for OSOL 2008.11

Jan Hnatek Jan.Hnatek at Sun.COM
Mon Feb 9 11:07:32 CET 2009

Hi Michael, Adriaan,

thanks for the tip. It did help, but this solves the problem
without a reboot
# svcs -x
# svcadm clear nwam

I encountered the problem with unlocking the screen. Did you
figure out which binary needs suid? Adding +s to
/opt/kde-4.1/lib/kde4/libexec/kcheckpass didn't help.

There's a couple of other bugs, but otherwise I'm impressed.

Random list of problems I've seen:
- the "Updating System Configuration" dialog end in an endless loop
  (upon saving in Menu Editor or in panel icon modification)
- keyboard randomly locks and mouse behaves as if Alt is pressed
   this seems to happen only after the above one
- system activity window is not displaying any processes (Ctrl-Esc)
- nwam tray monitor is started multiple times

I had to enable "force fonts DPI" to 96 to have acceptable appearance in
most applications, just thunderbird could use an exception. I don't know
how to do this (normally layout.css.dpi), since it's being overriden by

And this page
proved useful since I managed to remove the panel once.

Unfortunately, I only have limited amount of time to play with this
and investigate the issues. I was however thinking of creating a clone
from the repository, so that more people can try this and hopefully 
help. What to you think?

Thanks & regards,

Michael Schuster wrote:
> On 02/06/09 08:55, Jan Hnatek wrote:
>> Well, I updated to 106 from /dev yesterday,
>> just before pulling KDE. I was running on 105
>> for the last month.
>> Also, I had a couple of KDE packages already
>> in place from my attempts to build it (I think
>> FOSSqt and further up the dependency tree were pulled).
>> And I should probably add that I managed to break it nicely,
>> roughly like this:
>> - upgrade to 106
>>   reboot to opensolaris-3 (new zfs filesystem created by beadm)
>>   I used this for a day with no problem
>> - installed KDE
>> - ran KDE for a while
>> - tried to show a colleague one youtube video with KDE 4.2 demo
>>   tried fullscreen (slightly expecting it to break)
>>   which got me to a complete freeze
>> - when I rebooted, $HOME was not accessible...
> I've seen similar things happen when I do sth like:
> beadm mount <other BE> <mountpoint>
> .. do something on <mountpoint>
> reboot (without beadm umount!) into <other BE>
> then the <other BE> doesn't have /opt mounted.
> what I do to resolve is return to the initial BE, mount & umount the 
> other BE, reboot.
> Michael

Jan Hnatek
jan.hnatek at sun.com

More information about the kde-solaris mailing list