[kde-solaris] Building KDE 3.5.7 on Solaris Express (SXDE)

morgan henning morgan at hitechtx.com
Thu Oct 25 08:31:49 CEST 2007

Well, I don't know if reverting to a stock Solaris 10 (6/06) with the 
latest patches fixed my issue, or trying KDE 3.5.8 fixed it, but this 
comes to you from a konsole session on Solaris 10/x86.

For reference: below the libart stuff below seems to have been some kind 
of issue with the linker (a hand built gcc that used a hand built gnu ld 
worked for the same box, but I got some other errors, so I tried S10 
again).  The library was there.  I was pointing to it in every way I knew 
how...  My LD_LIBRARY_PATH pointed to it, and all manner of compile time 
flags didn't solve the issue (nor did the hand made (?) .la file, but I 
learned about libtool from that one :) ).

With my current config, the Sun included gcc 3.4.3 built KDE fine.  I 
don't think that this was the case before, but I've tried this so many 
times in the past couple months, that I don't remember all the gyrations 
that I went through.

Now, after building a base KDE (kdelibs, kdebase, kdeartwork, and some 
more building now), I am going to see if I can make it work with all the 
possible support libraries KDE might want (OpenEXR, etc.).  If anyone's 
interested, I can send along the flags I use to build it all.  I have no 
idea if this would work on Sparc as a process, but until I have everything 
flushed out on x86, I am not going to put my poor Ultra 5 to work on KDE 
juuuust yet ;)

Has anyone else had good luck with KDE 3.5.8 ??

Morgan Henning
morgan at hitechtx.com

On Wed, 19 Sep 2007, Adriaan de Groot wrote:

> On Wednesday 19 September 2007 09:04, morgan henning wrote:
>> art_free(void*)                     ./.libs/libkdecore.so
>> art_alloc(unsigned int)             ./.libs/libkdecore.so
>> art_realloc(void*, unsigned int)    ./.libs/libkdecore.so
>> I am guessing these undefined symbols are in libart_lgpl_2.so, but I am
>> lacking the proper syntax to tell the build where to find them.  The
>> library doesn't have any permissions issues.  It's 32-bit.  My
> Use --with-extra-libs=/usr/local/lib or similar; it's strange that libkdecore
> would use libart but then not link to it properly.

More information about the kde-solaris mailing list