[kde-solaris] [Fwd: Re: [SunRay-Users] [Fwd: why is Xsun removing /tmp/.ICE-unix]]

Darin Perusich Darin.Perusich at cognigencorp.com
Tue Sep 5 21:43:10 CEST 2006


-------- Original Message --------
Subject: Re: [SunRay-Users]	[Fwd: [kde-solaris] why is Xsun removing
Date: Tue, 05 Sep 2006 13:21:24 -0400
From: Bob Doolittle <Robert.Doolittle at sun.com>
Reply-To: SunRay-Users mailing list <sunray-users at filibeto.org>
To: SunRay-Users mailing list <sunray-users at filibeto.org>
References: <44FD6820.3080201 at cognigencorp.com>


This would be a better question for the
desktop-discuss at opensolaris.org mailing list, since although there are
Sun Ray experts on this list what you describe seems to be a KDE
behavior, and would need to be fixed in KDE...  Or maybe somebody who
knows KDE could suggest a way to tune or configure KDE to avoid this

I can however suggest a better workaround - add the necessary code into
/usr/dt/config/Xsetup (this is invoked whenever a new X server starts
up, and runs with root permissions).  That's not a fix, but it's a
lighter-weight workaround.


Darin Perusich wrote:
> good morning all,
> this came up on the kde-solaris list over the weekend and thought
> that some here might be able to provide some insight into this issue.
> -------- Original Message -------- Subject: [kde-solaris] why is Xsun
> removing /tmp/.ICE-unix Date: Sun, 3 Sep 2006 16:43:33 +0200 From:
> Willi Burmeister <wib at cs.uni-kiel.de> Reply-To: For people using KDE
> on Solaris,  with questions about KDE or Solaris
> <kde-solaris at mail.kde.org> To: kde-solaris at mail.kde.org
> Hi,
> we have just updated all of our SunRay servers from Solaris 9 to
> Solaris 10.
> Most of our people are using KDE as desktop and this means the need
> write access to /tmp/.ICE-unix. KDE creates this directory during
> startup, but with wrong permissions. It's only writeable by the
> current user. Obviously this is a problem on the SunRay server.
> Before the update I solved this with a small script called during
> startup:
> mkdir /tmp/.ICE-unix chmod 1777 /tmp/.ICE-unix
> this worked without any problems.
> With Solaris 10 this directory ist removed any time Xsun is restarted
> :-(
> At a start I have created a cron job running every two minutes to
> recreate the directory with the right permissions. This is a very
> silly workaround.
> I think this is a bug, but maybe there a any good reasons for this 
> behaviour. Does anyone have an explanation for this? Or do I have to
> open a call?
> Willi
> P.S. also posted in comp.unix.solaris
> ___________________________________________________ This message is
> from the kde-solaris mailing list. Account management:
> https://mail.kde.org/mailman/listinfo/kde-solaris. Archives:
> http://lists.kde.org/. More info: http://www.kde.org/faq.html.

SunRay-Users mailing list
SunRay-Users at filibeto.org

Darin Perusich
Unix Systems Administrator
Cognigen Corporation
395 Youngs Rd.
Williamsville, NY 14221
darinper at cognigencorp.com

More information about the kde-solaris mailing list