[kde-solaris] why is Xsun removing /tmp/.ICE-unix

Darin Perusich Darin.Perusich at cognigencorp.com
Tue Sep 5 14:08:58 CEST 2006

i forwarded this to the SunRay-Users mailing list this morning, maybe
they can provide some insight. alot of eyes from sun watch that list,
including sunray engineers.

in case you're interested in subscribing...

SunRay-Users at filibeto.org

Willi Burmeister wrote:
> Hi,
> we have just updated all of our SunRay servers from Solaris 9 to Solaris 10.
> Most of our people are using KDE as desktop and this means the need write
> access to /tmp/.ICE-unix. KDE creates this directory during startup, but
> with wrong permissions. It's only writeable by the current user. Obviously
> this is a problem on the SunRay server.
> Before the update I solved this with a small script called during startup:
>   mkdir /tmp/.ICE-unix
>   chmod 1777 /tmp/.ICE-unix
> this worked without any problems.
> With Solaris 10 this directory ist removed any time Xsun is restarted :-(
> At a start I have created a cron job running every two minutes to recreate
> the directory with the right permissions. This is a very silly workaround.
> I think this is a bug, but maybe there a any good reasons for this behaviour. 
> Does anyone have an explanation for this? Or do I have to open a call?
> Willi
> P.S. also posted in comp.unix.solaris
> ___________________________________________________
> This message is from the kde-solaris mailing list.
> Account management:  https://mail.kde.org/mailman/listinfo/kde-solaris.
> Archives: http://lists.kde.org/.
> More info: http://www.kde.org/faq.html.

Darin Perusich
Unix Systems Administrator
Cognigen Corporation
395 Youngs Rd.
Williamsville, NY 14221
darinper at cognigencorp.com

More information about the kde-solaris mailing list