[kde-solaris] what have i done wrong?

Stefan Teleman steleman at nyc.rr.com
Sat Jan 29 00:13:24 CET 2005

On Friday 28 January 2005 17:50, Chris McCraw wrote:
> another was to fix /usr/openwin/share/include/X11/Xlibint.h :
> < #if (defined(__STDC__) && !defined(UNIXCPP)) || defined(ANSICPP)
> ---
> > #if (__STDC__ && !defined(UNIXCPP)) || defined(ANSICPP)
> so it would compile with gcc.

Ouch. /me cringes. :-) but i dont think that's the root of the 

> i can't remember any other patches now except to things like .pc
> files for pkgconfig to force inclusion of freetype2 and pangoxft's
> link libraries.  also as mentioned below, i had to mess with
> libtool but that was all to avoid local config issues;  nothing
> substantive.
> also i think i had to disable the rotation screensaver, though
> that may have been in a different package that i haven't rebuilt
> this round (i have only arts, kdelibs, and kdebase installed).
> finally i did put in all the patches on the page:
> 	http://www.kde.org/info/security/
> into place as well.
> in the end, all my make commands exited with a successful error
> code, so i don't think anything was noticeably broken during build.
> > - are the executables picking up the right libraries from the
> > right directory trees (in case you have several different
> > versions of the same library in different spots on your system)
> according to ldd, yes.  this took me almost a week to get right--
> libtool is a major PITA as regards passing my linker args right and
> NOT making me use the libraries in /usr/local/lib which are as you
> surmise different stale versions of what i was after.
> but now nothing is linked to any libraries outside of /lib and
> /usr/openwin/lib that i didn't build.  i am as sure of this as
> i am sure that ldd's output is right (i don't use LD_LIBRARY_PATH
> or anything)

ok. trick #1: to get rid of this /usr/local/lib nuisance with libtool: 
do a 
:1,$ s#/usr/local#<whatever-your-lib-dir-path-is>#g
in ./configure. also, change #!/bin/sh to #!/bin/bash

> > - did you notice compiler warnings flying by in xterm when you
> > were building
> tons and tons.

yeah i was somehow expecting that.

> a lot of them are gcc-3.4 specific about type-punned pointers (i
> can't recall whether those were in kde or its prerequisite libs). 
> a lot more were about the #pragma's in sun's include files (in
> almost every package i built), and redefinition of the LARGEFILE
> related macros. anything substantive while linking?  not that i
> recall.  but...frankly there were so many errors i stopped watching
> very carefully.
> > - can you run anything inside KDE (does it even start)
> it doesn't even visibly start.  the startkde script sets the
> background and starts to resume my session (if i have a .kde dir),
> but anything that draws on the screen basically crashes, starting
> with the splash screen, and kded, and ... (i include the output
> from a startup with this message).  some things like ksmscript and
> kdeinit run/stay running, but nothing useful, like the config
> dialog or the splash screen or konsole will run.

> i run an xterm before i start kde and i can still run other stuff
> from that xterm after it fails to start (but kdeinit is still
> around).
> > - do you see complaints in the KDE error log file, and if so,
> > what are they
> see for yourself (attached file, also available at URL:
> 	http://www.cs.utexas.edu/~fool/kde.out
> )
> > - did you by any chance read the installation instructions from
> > the KDE 3.3.1 releases (there are several tricky things which
> > need to be configured, independent of the compiler you use in
> > building)
> i followed the documentation in
> 	http://developer.kde.org/build/compile_kde3_3.html
> fully.  a linux build worked fine following those same instructions
> with the same versions of everything.

nah. that won't work -- forget that :-). solaris is a totally 
different beast. it needs very serious patching. i think gcc also 
needs to have ran the fixincludes script, to take care of its 
incompatibilities with system header files. 

> that's news.  you should put that on the web somewhere!  i'll try
> to rebuild it without xrender, but that will take all weekend even
> on my 4way sunfire 480...

it is in my release notes for the SunOne Studio builds ... :-)

this is the first thing i see in the startup log:


these directories must exist, be owned root:root and must have 
permissions 0777 with sticky bit set. i had to write a silly little 
program (lamely named kchmod) which sets these permissions from 
within startkde, before everything else starts. kchmod needs to be 
installed setuid root (so it can create these directories and set the 
permissions). i think i posted the source together with the source 
code patches (at KDE). let me know if it's not there and i will send 
you the source -- it's nothing spectacular really.

startkde should also run as #!/bin/bash not #!/bin/sh.

the rest of your kde startup log needs some more contemplation on my 
part. :-)


Stefan Teleman          'Nobody Expects the Spanish Inquisition'
steleman at nyc.rr.com                          -Monty Python

More information about the kde-solaris mailing list