[kde-solaris] Compiling problems

mark_tinges at ftsi.fujitsu.com mark_tinges at ftsi.fujitsu.com
Wed Apr 30 17:36:19 CEST 2003

Hi  everyone,

I need some help. I have imstalled and compiled Qt 3.0.4 on my Solaris 8
Machine.I installed the pre-built KDE packages. I am running gcc 3.1.1,
kdelib and base  3.0.1, kdedevlp 2.1.1, everything seemed ok, until I tried
to build ksetiwatch for my Sun......

here is a clip of what I believe the failure says......any ideas? I am new
to the kde environs.....Does it show?

taking that
tried NO
configure:19312: rm -rf SunWS_cache; g++ -o conftest -O2 -fno-exceptions
check-new -I/usr/local/qt/include   -DQT_THREAD_SUPPORT  -D_REENTRANT
_PTHREAD_SEMANTICS -DUSE_SOLARIS -DSVR4  -L/usr/local/qt/lib    conftest.cc
lqt-mt -lpng -lz -lm -ljpeg -ldl  -lXext -lX11 -lSM -lICE -lsocket  -lnsl
hread 1>&5
Undefined                       first referenced
 symbol                             in file
sunOglCurrentContext                /usr/local/qt/lib/libqt-mt.so
sunOglCurPrimTablePtr               /usr/local/qt/lib/libqt-mt.so
ld: fatal: Symbol referencing errors. No output written to conftest
collect2: ld returned 1 exit status
configure:19315: $? = 1
configure: failed program was:
#include "confdefs.h"
#include <qglobal.h>
#include <qapplication.h>
#include <qcursor.h>
#include <qstylefactory.h>
#include <private/qucomextra_p.h>
#if ! (QT_VERSION >= 303)
#error 1

More information about the kde-solaris mailing list