[kde-solaris] Solaris 8:kdenetwork-3.1.1 Compile problem

LeBar, Russell J Russell.J.LeBar at erac.com
Fri Apr 11 15:08:09 CEST 2003

Only problem I had here was with Kiten. I did a setenv DO_NOT_COMPILE krfb
to avoid that problem.

Kde 3.1.1, gcc 3.2.1, GNU binutils, Qt 3.1.2.

-- Russ LeBar x3355

-----Original Message-----
From: Enrique Ayesta Perojo [mailto:eayesta at portugalete.uned.es]
Sent: Friday, April 11, 2003 05:30
To: kde-solaris at mail.kde.org
Subject: [kde-solaris] Solaris 8:kdenetwork-3.1.1 Compile problem

Has anybody been able to compile kdenetwork on Solaris 8? 
There seems to be something nasty with the SUN includes (bugs.kde.org: BUG# 
51743) and it's definition of truncate64 and open64 functions, i've tried
proposed patch creating a new unistd.h under $KDEDIR/include/ undefining 
truncate, but later i get the same error in kmail with open function and 
creating a new filecntl.h in the same way doesn't help. Any idea?

Trying to compile using:

Thanks in advance
This message is from the kde-solaris mailing list.
Account management:  http://mail.kde.org/mailman/listinfo/kde-solaris.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde-solaris mailing list