[kde-solaris] Solaris 8:kdenetwork-3.1.1 Compile problem

Torsten Kasch tk at Genetik.Uni-Bielefeld.DE
Fri Apr 11 13:58:35 CEST 2003


On Friday 11 April 2003 12:30, Enrique Ayesta Perojo wrote:
> Has anybody been able to compile kdenetwork on Solaris 8?
> There seems to be something nasty with the SUN includes (bugs.kde.org: BUG#
> 51743) and it's definition of truncate64 and open64 functions, i've tried
> the proposed patch creating a new unistd.h under $KDEDIR/include/
> undefining truncate, but later i get the same error in kmail with open
> function and creating a new filecntl.h in the same way doesn't help. Any
> idea?

I've had the same problem, and it doesn't seem to be Sun's problem, it's gcc 
<= 2.95.3 that lacks the "#pragma redefine_extname" capability (see BR#51829 
for details).

For some reason (although I used "--disable-largefile" during configure), all 
Makefiles have "-D_FILE_OFFSET_BITS=64 -D_LARGE_FILES=1" in their CPPFLAGS. I 
don't know where this comes from (doesn't seem to be the *.am or admin/* 
files), but the only way I got kdenetwork to compile was to remove those two 
defines from kdenetwork's Makefiles...


   Torsten Kasch                               tk at Genetik.Uni-Bielefeld.DE
        Biologie VI/Zentrum f. Genomforschung
        Universität Bielefeld                  Phone: +49 521 106-4828
        D-33594 Bielefeld                      Fax:   +49 521 106-5626

More information about the kde-solaris mailing list