Koto: Progress Report... umm... #3?

Iain Dooley idoo4002 at mail.usyd.edu.au
Tue Aug 30 16:22:27 CEST 2005

hello kde SoCers,

Koto has been completed as far as SoC deliverables are concerned, and is 
working quite nicely. you can load any .ui file and edit ruby code at 
runtime to handle signal connections. i can't wait to release it so that 
my fellow programmers can try it out, but there is one tiny barrier ...

the distribution of this thing is driving me seriously nuts! i read the 
"Goat Book" this afternoon and felt as though i came out more confused 
than when i went in. i've tried importing into KDevelop to use the 
automake manager, but i couldn't get that to work either, so i tried 
starting a new QMake project in KDevelop. i got it building from within 
KDevelop, and found out how to use the "-l" flag to qmake in order to 
use ld to link against .so files. also, the "smoke.h" header file is 
included in the 'include' directory of any distribution that has smoke 

the biggest problems now are ruby and qtruby libraries. there is 
qtruby.h that i need to link to, but this is not included in the 
'include' directory when qtruby is installed. qtruby.h, and 
libqtrubyinternal.a are two files that i need to include and link 
against respectively, but neither of them are actually supposed to be 
used externally. is my only option here to include the entire qtruby 
source in my project?

also, the ruby library directory does not appear to be in a standard 
location. on my machine, the file i need is in:


obviously this is not going to be the same for non-freebsd 5.x users!! 
how can i possibly find out where this ruby lib directory is on someone 
else's machine?

if anyone has any magical solutions or handy suggestions (for instance, 
some brilliant command that just looks at my project and fixes 
everything for me... ) then i would LOVE to hear about it.

otherwise, pray for me ...



More information about the Kde-soc mailing list