[Kde-pim] Review Request 121580: Small API review for KContacts
Milian Wolff
mail at milianw.de
Wed Dec 17 16:12:31 GMT 2014
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/121580/#review72193
-----------------------------------------------------------
yay nice work Aleix!
autotests/addresstest.cpp
<https://git.reviewboard.kde.org/r/121580/#comment50357>
QStringLiteral, also below
src/address.h
<https://git.reviewboard.kde.org/r/121580/#comment50358>
\o/
src/addressee.cpp
<https://git.reviewboard.kde.org/r/121580/#comment50359>
remove this and parametrize on the container type above, i.e.:
template<class List>
static bool listEquals(const List &, const List &);
maybe even use two list types. The code below stays the same.
src/addresseehelper.h
<https://git.reviewboard.kde.org/r/121580/#comment50361>
move that also to a free function in an anonymous namespace in the .cpp file
src/addresseehelper.h
<https://git.reviewboard.kde.org/r/121580/#comment50360>
QScopedPointer
src/addresseelist.cpp
<https://git.reviewboard.kde.org/r/121580/#comment50362>
QStringLiteral
src/ldifconverter.h
<https://git.reviewboard.kde.org/r/121580/#comment50363>
not exported anymore? then remove it from the public header, no?
- Milian Wolff
On Dec. 17, 2014, 4:10 p.m., Aleix Pol Gonzalez wrote:
>
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://git.reviewboard.kde.org/r/121580/
> -----------------------------------------------------------
>
> (Updated Dec. 17, 2014, 4:10 p.m.)
>
>
> Review request for KDEPIM.
>
>
> Repository: kcontacts
>
>
> Description
> -------
>
> - fixes a couple of remaining rename issues (kabc->kcontacts)
> - QList->QVector from public API. It's been discussed many times, it doesnt' make much sense to use QList there.
> - Moved AddresseeHelper attributes into a d-pointer.
> - Kill ErrorHandler, it didn't have any users anyway.
> - Added Geo::clear() method, for consistency.
>
>
> Diffs
> -----
>
> autotests/addresstest.cpp fd36f23
> src/CMakeLists.txt 4772805
> src/address.h 69b263d
> src/address.cpp a6e1e84
> src/addressee.h cef3bac
> src/addressee.cpp fca731e
> src/addresseehelper.h 7c85462
> src/addresseehelper.cpp e1d0974
> src/addresseelist.h 1114c6a
> src/addresseelist.cpp 6acf9ae
> src/errorhandler.h d09e097
> src/errorhandler.cpp 9475619
> src/geo.h 93b4e87
> src/geo.cpp 92f62af
> src/key.h 5203422
> src/ldifconverter.h abc987d
> src/phonenumber.h a8d96da
> src/vcardtool.h 292df6d
>
> Diff: https://git.reviewboard.kde.org/r/121580/diff/
>
>
> Testing
> -------
>
> Tests pass, I still can use KTp+KPeople without crashes.
>
>
> Thanks,
>
> Aleix Pol Gonzalez
>
>
_______________________________________________
KDE PIM mailing list kde-pim at kde.org
https://mail.kde.org/mailman/listinfo/kde-pim
KDE PIM home page at http://pim.kde.org/
More information about the kde-pim
mailing list