[Kde-pim] Re: Review Request: Make Akonadi item's id and url available to script actions.

Ingo Klöcker kloecker at kde.org
Sun Feb 13 15:21:58 GMT 2011


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://git.reviewboard.kde.org/r/100645/#review1407
-----------------------------------------------------------


AFAICS neither of the two new member functions use any class members. Consequently, they do not need to be member functions. I suggest putting them into an unnamed namespace in the cpp file instead of needlessly polluting the header with private methods.

Other than that (and the coding style issues below) the change looks fine.


mailcommon/filteraction.h
<http://git.reviewboard.kde.org/r/100645/#comment1176>

    Coding style: "For pointer and reference variable declarations put a space between the type and the * or & and no space before the variable name."
    
    Same rules for everybody. ;-)



mailcommon/filteraction.cpp
<http://git.reviewboard.kde.org/r/100645/#comment1177>

    coding style (see above)
    
    Also: inconsistent naming of second parameter (commandLine in declaration and result in definition).



mailcommon/filteraction.cpp
<http://git.reviewboard.kde.org/r/100645/#comment1178>

    Coding style: "Put spaces between brackets and arguments of functions"


- Ingo


On Feb. 13, 2011, 1:08 p.m., Till Adam wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://git.reviewboard.kde.org/r/100645/
> -----------------------------------------------------------
> 
> (Updated Feb. 13, 2011, 1:08 p.m.)
> 
> 
> Review request for KDEPIM.
> 
> 
> Summary
> -------
> 
> With this patch, the Akonadi item's id and url are available for the script/program execution and pipe-through filter actions. This allows scripts that process the message to store a reference to the item/message which can then later be used to find it again. 
> 
> 
> Diffs
> -----
> 
>   doc/kmail/using-kmail.docbook 879669e 
>   mailcommon/filteraction.h ca4c5ae 
>   mailcommon/filteraction.cpp d86a12a 
> 
> Diff: http://git.reviewboard.kde.org/r/100645/diff
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Till
> 
>

_______________________________________________
KDE PIM mailing list kde-pim at kde.org
https://mail.kde.org/mailman/listinfo/kde-pim
KDE PIM home page at http://pim.kde.org/



More information about the kde-pim mailing list