Multimedia that *just works*, pretty please!

Martin Steigerwald martin at
Sun Sep 20 14:37:55 BST 2015

Please reply only to one list if you reply – even though I think its high time 
that people work together for a grander, unified view on how to handle 
multimedia within Linux. As I am not subscribe to alsa-devel, please Cc me in 
case you reply to this list.

And yes, this is a rant. But it based a huge lot of real life experiences with 
multimedia on Linux just not working right for me and various machines I use 
for myself or installed for others.

While I appreciate that it may just work okay for quite some people, I also 
think no amount of denial will make the cases where it currently breaks like 
it breaks for me on various machines go away. Am I the only one? I don´t know, 
but I do not think so.


I have a dream, a simple dream:

Multimedia that *just works*.

That means:

- music playing: I have a play list, select a song and when I press play, it 
just starts playing. *All of the times*. Like my Kenwood CD player. It works. 
*All of the time*.

- when I play a music in any app, it always plays with the same settings on 
the same device through the same backend.

- in the rare event there is a real user error, it tells me so, in the GUI.
   - specifically it doesn´t just not start playing like Amarok in Debian Sid 
with phonon gstreamer backend *without* any visible user feedback whatsoever. 
no matter whether without or with pulseaudio.

- also it does not break any third party apps
   - specifically it doesn´t make the sound stutter in PlaneShift game which 
uses OpenAL like installing Pulseaudio does¹

- and most importantly: It is simple enough that it gives me a fair chance to 
find the cause of the error in case there is one.
   - It is even simple enough that it doesn´t need hours over hours on trying 
a gazillion different options to combine various parts of the audio stack to 
make audio playback work in case after some upgrade it doesn´t anymore.

- It works with USB sound speakers *out of the box*.

- Playback is *stutter* free. All of the times. The Amiga was able to do that 
20 years ago and so can Linux.

Multimedia my Plasma 5 Linux desktop for me isn´t that. And it wasn´t that in 
KDE SC 4 times as well.

Multimedia in my Plasma 5 setups is embarrassing. Friends even joke at me 
whenever we watch a video here – and they have a point to make. When newest 
VLC selects a dsnoop device from the USB front speaker without *any* apparent 
reason and *against* being told to use a specific device in its settings. And 
I have to tell it to use the right device every single time I start the app. 
Or at times where the machine didn´t play the audio at all. While at the same 
time *none* of the other players work out of the box. Not Dragon Player, not 
Kaffeine, insert your favorite mplayer fork, not Totem player, not anything. 
So what I get with VLC here is still the *best* experience.

And with Amarok? I am seriously fed up with fixing up audio playback every now 
it then when it breaks for no apparent reason to me. Somehow I always get it 
to work, well except today, it still doesn´t work on one machine, and I have 
no idea why. And seriously – isn´t this supposed to be as simple as pressing 
"play" on my CD player or my the Rockbox based Sansa e260?

Is it just me?

I repeatedly get the impression that multimedia under Linux is a total, 
complete, utter mess. A complete disaster. And I get this impression out of 
real life experiences I make.

Once I try something more than a simple I play audio within one app from the 
internal speakers it has a tendency to break down.

Basically I get the impression that it is an accident when it works aside you 
staying in a simple one app with internal speaker scenario and even then it 
can break as I found out today.

I think its not just one single component causing this. I relate this to the 
complete Linux audio stack.

I dream of multimedia developers of all kinds come together to clean up the 
mess. I´d even be willing to attend and test all kinds of combinations, if, 
please, if, the amount of possible combinations to use to *just* play audio is 
reduced to an amount of combinations that anyone with some sanity left can 
work with.

I am so seriously fed up with the state of multimedia in my Plasma desktop on 

In my experience currently it is a complete disaster.

I just want to shout "keep it simple!" at it all the time.

Thank you for reading this far and please note that I do not mean this as a 
personal attack. I know its no one´s fault. I know you pour your labor of love 
into the parts of the multimedia stack you care about. I appreciate and honor 

I know I am using Debian Sid, I know its Phonon Qt4 => Qt5 transition, I know 
its only a bit after G++ ABI transition. But I have seen issues often enough 
on stable releases of Debian. What I described here is just the tip of the 

I switched the box that made so much trouble today to Pulseaudio now. Playback 
in Amarok still doesn´t work with Phonon gstreamer backend. Amarok currently 
crashes with Phonon VLC backend. I may try to compile the Qt5 version of 
Amarok to see whether it behaves better. At least Clementine plays. So its 
Clementine for now.

My main machine is still without Pulseaudio and will be, until I know how to 
fix stuttering audio playback in PlaneShift. I play this game regularily and I 
am just not going to install anything that breaks it. And at least here Amarok 
starts with VLC phonon backend.

I am willing to provide debug output and help testing to make things work, but 
I definately need guidance as I have no idea where to look for errors. Is it 
Phonon? Is it Pulseaudio? Is it PlaneShift game? Is it ALSA? Is it VLC? Is it 
Gstreamer? Frankly, I have no idea anymore. And I think thats not due to a 
lack of intelligence.

¹ [Bug 85445] New: PlaneShift with OpenAL sound  stutters: PulseAudio returned 
minreq > tlength/2; expect break up

I seriously consider reporting this with PlaneShift developers as well. Maybe 
out of whats in there they can fix something within the game, but as it works 
with ALSA just fine… Please don´t just break userspace apps that work fine 
with ALSA.

kde-multimedia mailing list
kde-multimedia at

More information about the kde-multimedia mailing list