[Phonon][Patch] add a method to get the current frame number

Tanguy Krotoff tkrotoff at gmail.com
Fri Mar 28 01:23:51 GMT 2008


On Thu, Mar 20, 2008 at 7:40 PM, Matthias Kretz <kretz at kde.org> wrote:
>  Perhaps it should be called currentVideoFrame() since there are also audio
>  frames (just 48000 per second instead of ~25). And I omitted "Number" to not
>  make the function name too long.

I think term Number is good since currentVideoFrame() can "mean" something else
like:
qint64 videoFrameId = obj->currentVideoFrame();
or
VideoFrame videoFrame = obj->currentVideoFrame();
videoFrame->size();

Why not Nb?
Number is used by Qt API, not Nb
cf http://doc.trolltech.com/main-snapshot/functions.html

>  Other functions that could be added later are:
>  qint64 videoFrameCount()
>  void seekToVideoFrame(qint64)

seekToVideoFrameNumber()
to make it symmetric, even a longer name :/

-- 
Tanguy Krotoff <tkrotoff at gmail.com>
+33 6 68 42 70 24



More information about the kde-multimedia mailing list