Assertion fail in mcoputils

Patric A. v. Löwis of Menar kde at
Mon Dec 16 17:55:58 GMT 2002

On Monday 16 December 2002 17:12, Patric v. Loewis of Menar wrote:
> Hi,
> i've been trying to compile & install a new kdedesktop for about three
> weeks now. There is one common problem i have with all versions from 3.0.5
> to 3.1-rc(1-5):
> On startup and every time i try to startup konqueror there a complaint
> about a failing assertion c != '\n' in line 257 of function
> tokenize.
> So far i tried changing the compiler (gcc 3.2/3.2.1), reinstalled the
> alsa drivers (0.9.0rc6), tried different kernels (2.4.4/19/20), and
> everytime deleted /tmp/* and all kde related files inside my home dir
> (.kde, .kde-rc, .mcoprc, etc.).
> When disabling the assertion knotify pops up endles times.
> I guess i must be missing something extremely trivial. I'd really
> appreciate any hint as to what i'm doing wrong here.
My apologies. The line is:

vloewis at Nuschka:~/alsa/alsa-lib-0.9.0rc6 > artscat
file ../../mcop/ line 264 (static bool 
Arts::MCOPUtils::tokenize(const std::string&, std::string&, 
std::vector<std::string, std::allocator<std::string> >&)): assertion failed: 
(c != '\n')

More information about the kde-multimedia mailing list