[KDE/Mac] Frameworks build error on Mavericks

Nicolas Pavillon nicos at macports.org
Fri Apr 18 10:09:43 UTC 2014


I am afraid I do not any good answer on the spot. I never tried to build Frameworks either, would it be independently or through Macports. 

The error also does not ring any bell. I encountered cases where it was necessary to add an explicit include to unistd.h to compile on Mac (but I can’t remember if it was for a KDE package or not), but no errors due to mismatching constants. 

One thing though is that to my understanding the port is built independently. In the case of Macports for KDE4, we have a whole port group (kde4-1.1.tcl) to define constants and environment variables to build KDE packages somewhat properly. It may be useful to look at its definitions. The file can be seen online (instead of downloading the whole package) at: http://trac.macports.org/browser/trunk/dports/_resources/port1.0/group/kde4-1.1.tcl?rev=115590. 



On Apr18, 2014, at 11:43, Ian Wadham <iandw.au at gmail.com> wrote:

> Hello Allen and KDE/Mac guys,
> On 18/04/2014, at 10:15 AM, Allen Winter wrote:
>> I'm trying to build frameworks on my old MacBook pro running mavericks.
> I have not installed Mavericks yet, nor tried to build Frameworks yet.
> I will forward your query to the kde-mac mailing list and see if one
> of our KDE/MacPorts developers can answer it.  Brad?  Nicos?
> Maybe you can help them too, Allen.  MacPorts is at an early stage
> with porting Qt5 and KF5 IIUC.
> Frameworks is aka KF5 (the 5th generation of KDE software).  Allen is one
> of the longest-serving KDE guys https://community.kde.org/KDE_PIM/People
> I hope we can help him.  Please CC Allen in case he is not subscribed.
>> One problem I encountered building karchive is the following:
>> [  5%] Building CXX object src/CMakeFiles/KF5Archive.dir/karchive.cpp.o
>> /data/kde/src/5/frameworks/karchive/src/karchive.cpp:231:19: error: use of undeclared identifier 'readlink'
>>       int len = readlink(encodedFileName.data(), s.data(), s.size() - 1);
>>                 ^
>> 1 error generated.
>> seems that unistd.h isn't getting into  __DARWIN_C_LEVEL >= 200112L
>> conditional compile that declares readlink().
>> do you know what I'm doing wrong? or maybe there's a compile flag missing?
>> I tried adding -ansi but that didn't help.
> Cheers, Ian W.
> _______________________________________________
> kde-mac at kde.org
> List Information: https://mail.kde.org/mailman/listinfo/kde-mac
> KDE/Mac Information: http://techbase.kde.org/index.php?title=Projects/KDE_on_Mac_OS_X

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-mac/attachments/20140418/e06ae100/attachment.html>

More information about the kde-mac mailing list