[KDE/Mac] Frameworks build error on Mavericks

Ian Wadham iandw.au at gmail.com
Fri Apr 18 01:43:27 UTC 2014

Hello Allen and KDE/Mac guys,

On 18/04/2014, at 10:15 AM, Allen Winter wrote:
> I'm trying to build frameworks on my old MacBook pro running mavericks.

I have not installed Mavericks yet, nor tried to build Frameworks yet.
I will forward your query to the kde-mac mailing list and see if one
of our KDE/MacPorts developers can answer it.  Brad?  Nicos?

Maybe you can help them too, Allen.  MacPorts is at an early stage
with porting Qt5 and KF5 IIUC.

Frameworks is aka KF5 (the 5th generation of KDE software).  Allen is one
of the longest-serving KDE guys https://community.kde.org/KDE_PIM/People
I hope we can help him.  Please CC Allen in case he is not subscribed.

> One problem I encountered building karchive is the following:
> [  5%] Building CXX object src/CMakeFiles/KF5Archive.dir/karchive.cpp.o
> /data/kde/src/5/frameworks/karchive/src/karchive.cpp:231:19: error: use of undeclared identifier 'readlink'
>        int len = readlink(encodedFileName.data(), s.data(), s.size() - 1);
>                  ^
> 1 error generated.
> seems that unistd.h isn't getting into  __DARWIN_C_LEVEL >= 200112L
> conditional compile that declares readlink().
> do you know what I'm doing wrong? or maybe there's a compile flag missing?
> I tried adding -ansi but that didn't help.

Cheers, Ian W.

More information about the kde-mac mailing list