[KDE/Mac] New Packages. Almost, but not quite KDE 4.1.2 universal.

William Holland will at willholland.co.uk
Sat Oct 4 19:33:04 CEST 2008

Thanks for the quick reply.

From those packages, dbus fails to restart.  Once I've started it (as root), I 
get the same old mime type errors, but I've noticed that there appears to be 
a dbus problem again mentioned at the beginning of the kbuildsycoa4 output:

will-hollands-macbook:local will$ /opt/local/bin/kbuildsycoca4 
kbuildsycoca4(374) mac_initialize_dbus: "/bin/launchctl" never wrote anything
kbuildsycoca4(374) mac_initialize_dbus: warning: unable to initialize D-Bus 
kbuildsycoca4(374)/kdecore (kdelibs) getBundle: 
getBundle( "/opt/local/lib/kde4/libexec/drkonqi" ,  false ) called
kbuildsycoca4(374)/kdecore (kdelibs) getBundle: getBundle(): 
returning  "/opt/local/lib/kde4/libexec/drkonqi.app/Contents/MacOS/drkonqi"
process 374: D-Bus library appears to be incorrectly set up; failed to read 
machine uuid: Failed to open "/opt/local/var/lib/dbus/machine-id": No such 
file or directory
See the manual page for dbus-uuidgen to correct this issue.
  D-Bus not compiled with backtrace support so unable to print a backtrace

running dbus-uuidgen --ensure helps a little, but I still get the 
mac_initialize_dbus: warnings... I suspect that's the root of the issue.

Anyway, I'm happy to be an alpha tester, (I'm used to living on gentoo's 
bleeding edge, but have recently got myself a mac, which I'm slowly getting 
used to - great ui, but I'm still running kmail under parallels ;), so let me 
know if you need one.

I'll wait till slightly more user friendly packages appear.



On Saturday 04 October 2008, Big O wrote:
> On Sat, Oct 4, 2008 at 7:51 AM, William Holland <will at willholland.co.uk> 
> > Thanks,  I guessed it was just running setup scripts...
> >
> > I've re-installed from the individual packages however I still have the
> > same problem - mime-types misbehaving.
> Install from the kdeprereqs.dmg, restart the machine,  run
> kbuildsycoca4, then start whichever apps you want.
> > Amarok gives the message:
> > No Mime types installed.  Check that shared-mime-info is installed and
> > XDG_DATA_DIRS is not set, or includes /usr/share
> >
> > Running kbuildsycoa4 give errors similar to:
> > kbuildsycoca4(4568)
> > KBuildServiceFactory::populateServiceTypes: "gvpart.desktop" specifies
> > undefined mimetype/servicetype "image/jp2"
> > kbuildsycoca4(4568)
> > KBuildServiceFactory::populateServiceTypes: "gvpart.desktop" specifies
> > undefined mimetype/servicetype "image/png"
> >
> >
> > I've tried removing:
> > /opt/local
> > /Applications/KDE4
> That's not going to help. If you've deleted these directories then :
> install kdeprereqs.dmg, qt.dmg, kdesupport.dmg and then kde.dmg in that
> order. The individual dmgs were meant for people (developers really) who
> knew what they were doing but I didn't make that clear (or execute it
> particularly well) :-)
> Everybody else should use the dmgs above.
> >snip

More information about the kde-mac mailing list