[kde-linux] A question of middle button cut/paste with fedora 20 kde

George R Goffe grgoffe at yahoo.com
Sun Jan 25 08:44:39 UTC 2015


Thank you for your masterful description of this feature.

I was aware of the MS way of cut/paste but did not specifically select this behavior and did not use the "right" terminology to describe this behavior either. I've used X11 quite a bit and have been gnashing my teeth since my KDE (klipper), which is running by the way, has been doing the MS way and not the X11 way.

The scissors did bring up a config dialog (popup) but it doesn't make any sense to me but it's late here so I'll revisit this in the morning. Perhaps my klipper is broken or experienced some sort of abort. This is Fedora 20 and I'm a little new to this version having come from Fedora 19 where I did NOT have this problem. None of the klipper config changes appear to have worked though. I'm trying to copy/paste the URL from a Firefox browser (Firefox 35.0). This behavior has NOT changed with any of my klipper config changes. Any thoughts on this?

I intend to restart this system in a while to test the theory that klipper experienced some sort of abort. Maybe this will activate the changes in klipper config that I made as well. Who knows?

I'll report back here with my findings.

Thanks again for your response,


Message: 1
Date: Fri, 23 Jan 2015 23:25:55 +0000 (UTC)
From: Duncan <1i5t5.duncan at cox.net>
To: kde-linux at kde.org
Subject: Re: [kde-linux] A question of middle button cut/paste with
    fedora    20 kde
Message-ID: <pan$3a2d$ca0b46a1$ca34e890$953a832b at cox.net>
Content-Type: text/plain; charset=UTF-8

George R Goffe posted on Fri, 23 Jan 2015 09:20:14 +0000 as excerpted:

> I have noticed that my middle button cut/paste is not pasting the data
> that I have cut/copied. Is this a bug with KDE or is it a UFU (User Foul
> Up)... namely, my own?

It's a bit tough to say with the posted information.  Here's a couple 
generally related observations, tho, that with a bit of luck will help 
sort it out...

1) It's not clear from your question whether you're aware of the 
difference between xorg's select/paste and the more MS-user-familiar
copy/paste mechanisms, both of which kde supports, and if you are aware, 
which of the two (or both) you were having issues with.

1a) X-style select/paste pastes the last /selected/ content -- there's no 
need to specifically cut/copy it first.  Paste using this method is 
traditionally accomplished using the middle mouse button, which you 
mentioned, implying you had this in mind even tho you specified cut/copy 
instead of select.

1b) MS-style cut/copy/paste works a bit differently.  In addition to 
selecting content, you must trigger a specific cut/copy/paste action 
using either the keyboard shortcuts (which by cross-platform default are 
ctrl-x to cut, ctrl-c to copy, ctrl-v to paste), or the associated toolbar 
buttons.  Your use of cut/copy instead of select implies that you had 
this in mind, despite the fact that you also mentioned middle-mouse-
button paste, which normally has nothing to do with this method.

So as I said, it's ambiguous whether you meant MS-style cut/copy/paste or 
X-style select/paste, since you used terms implying both, which in turn 
indicates that you may in fact not be aware of the difference at all, 
particularly given that you didn't specifically mention the difference 
and to which you were referring.

2) Klipper is a kde-default select/cut/copy/paste AKA "clipboard" helper 
tool that normally starts with kde, with configuration available from the 
klipper icon normally found in the system tray.  (Look for a pair of 

Normally klipper will keep a configurable number of clipboard history 
entries on a stack, instead of the single one otherwise available in each 
of the two separate styles above (thus one for MS-style cut/copy/paste, 
one for X-style select/paste).

Also configurable is whether klipper synchronizes the contents of the two 
otherwise separate clipboard buffers or not.  If it is set to 
synchronize, then you may see accidental X-style selections before 
pasting override your MS-style paste buffer, such that when you use MS-
style paste, you get the accidental X-style selection pasted instead.

There are additional configuration options controlling whether selection 
is ignored (if you prefer MS-style and the X-style selection keeps 
accidentally getting pasted instead of the MS-style cut/copy buffer), 
whether an empty clipboard buffer is allowed, whether images are ignored 
and whether only text selection is allowed.

Meanwhile, on a different tab, there's a place to configure popup 
actions, which some find helpful and others irritating, and a way to 
disable these actions if you find them irritating.

I strongly suspect that your problems have to do with klipper.  Either 
it's not running for some reason and you simply need to start it 
(possibly after installing it, I run gentoo and not fedora, so I haven't 
a clue whether fedora's default kde install includes klipper or not), or 
it's running but is now configured differently than you are used to, and 
is thus behaving differently.  If it's the latter, playing with the 
configuration a bit should help.

Unfortunately, beyond that it's impossible to say given the posted 
information, because there simply wasn't that much actually posted to go 

But that should get you pointed in the right direction, at least.  With a 
bit of luck it'll be enough to let you fix it yourself.  If not, let it 
be a guide to posting additional information about which of the two 
methods (or both) you were talking about, whether klipper is running or 
not, and if running, what its configuration is.  That should help in 
further narrowing down and hopefully solving the problem. =:^)

Duncan - List replies preferred.   No HTML msgs.
"Every nonfree program has a lord, a master --
and if you use the program, he is your master."  Richard Stallman

More information about the kde-linux mailing list