[kde-linux] KDESU doesn't work again with 4.10

Dale rdalek1967 at gmail.com
Sun Apr 21 06:01:28 UTC 2013

James Tyrer wrote:
> I installed the link to: "kdesu" and I found that a desktop fine that
> used it doesn't work.  The file had:
> Exec=kdesu -c "konqueror --profile filemanagement /" --caption "SU
> Root KFM"
> {that is one line}
> Instead of Konqueror, I get a window titled: "Konqueror - The KDE
> Crash Handler" reporting that Konqueror crashed.  So KDESU must have
> worked and called Konqueror, but not correctly as it immediately crashed.
> Since I had previously fixed the bug in KDESU that prevented it from
> working, I was a bit disappointed. :-(
> Could this be something that I am doing differently?  Before I
> finished building KDE, I was using TWM with X11 and I noticed while
> running as my user account, I opened an Xterm, did: "su -" and
> attempted to open konqueror that it crashed with a message that I had
> to first enter an instruction to so that D-Bus was running.  So, I
> followed the instructions in Beyond Linux From Scratch to have BASH
> start and stop D-Bus with the profile and logout scripts -- something
> I had not done in my previous installation.  That cured that problem.
> I also note that this hack:
>  Exec=kdesu -c 'bash -l -c "konqueror --profile filemanagement /"'
> --caption "SU Root KFM"
> {again, this is one line}
> makes my desktop file open Konqueror as root with the "filemanagement"
> profile and the "/" directory just fine.  However, if this isn't
> specific to my system and how I am handling starting D-Bus, it appears
> that this hack is a work around for a bug and that KDESU should check
> to see if D-BUS is running and if it isn't, it should start it before
> calling the application that is to be opened.
> I also note that the: startkde script fails to detect that D-Bus is
> running and there are two of them running.  But, that is a minor bug.

I still use Konqueror as root too.  I have a menu item set up this way. 
For command:  "kfmclient openProfile filemanagement" and then I set it
to run as user root under advanced.  It works even after the upgrade and
has worked for quite a while now. 

When I select the item, it asks for the root password and then opens
Konqueror with root access.  This may be a different way but maybe you
can use that as a guide.

Hope that helps. 


:-)  :-) 

I am only responsible for what I said ... Not for what you understood or how you interpreted my words!

More information about the kde-linux mailing list