[kde-linux] 'Fetch Error' on exit

Duncan 1i5t5.duncan at cox.net
Wed Feb 8 20:27:22 UTC 2012

Alex Schuster posted on Wed, 08 Feb 2012 18:33:44 +0100 as excerpted:

> I have some strange problem with mplayer exiting when I press a key, so
> I want to use mplayer2. When changing this in the 'Open with...' dialog,
> a window with a progress bar appears, and the progress bar goes from 0
> to 100 % over and over again, every time becoming slower, until I abort.
> This started workin after another relogin into KDE.

I had that updating config repeating slower and slower bug some years 
ago.  IIRC it was due to kded (kde daemon, responsible for keeping 
running kde apps aware of changes to the config) problems, rooted in a 
kernel bug due to inotify/dnotify/whatever (one of the mechanisms that 
allows an app to tell the kernel to notify it if a file/directory 
changes) not working correctly.  The thread normally sleeps, waiting for 
the kernel to wake it up when there has been a change, but due to the 
bug, the thread would get stuck and quit responding.  The only way out 
was a kill -9 (force-kill) on the unresponding kded, which would leave it 
in a zombie state until reboot.  However, I could then restart kded and 
it would work... until the next time I tried to update something.

But that kernel bug only existed for a month or so in a pre-release 
kernel, broken during the pre-rc1 merge window, and fixed by rc5 or rc6 
or so I think, well before "gold" release of the new kernel.  It drove me 
crazy as I was doing a bunch of updates at the time (maybe it was while I 
was still converting from kde3 to kde4, IDR for sure, but for whatever 
reason, I had a lot of configuration updates happening during the period, 
so ran into this constantly), but I've not had a problem with it since.

So something similar is probably what was happening to you.  kded was 
failing to respond for whatever reason, perhaps due to a kernel issue 
with *notify as was the case way back when here, so the update code tries 
over and over to do the update, giving the unresponsive kded more time 
before timeout each time.  A kde logout/login cycle restarted kded, so 
the update process worked normally again.

... Meanwhile, talking about mplayer...

I'm a bit happy yet frustrated ATM, because for the first time ever, I'm 
able to run my radeon hd4650 with the gallium r600g mesa driver that's 
getting all the new development (the classic radeon OpenGL r600 driver is 
now considered legacy and in maintenance mode), with effects on, without 
hard-locking the entire machine (not even magic-srq-b/reboot would work!
), as it used to do *EVERY* time, just as it got to the desktop.

I'm not sure what fixed that bug, kde 4.8, or kernel 3.3-rcX, or mesa 8-
rc2, or xorg-server 1.11.4, or libdrm 2.4.30, or a combination of several 
of the above, but it works now, and I'm *QUITE* happy about it!

The /problem/ is that while kde now works just fine with the r600g 
gallium driver, mplayer locks up the entire system a few seconds into a 
video just as hard as kde/kwin/whatever /used/ to lock it up!  IOW, not 
even alt-srq-b (magic-srq reboot) works!  The kernel's hard-locked!

Fortunately, I have vlc installed as well, and I found out some time ago 
when mplayer was hard-locking my intel-based netbook, that it apparently 
doesn't use the same optimization levels as mplayer and thus works where 
mplayer will hard-lock the entire system.  But while it may not be /
quite/ as optimized, it does seem to be optimized /enough/.  So I've been 
switching stuff over to use vlc instead.

So I've been doing some mimetype config updates here, too.  Fortunately 
the kernel problems with dnotify or whatever are years gone by now, and 
that hasn't been causing problems, tho every once in awhile I'll click on 
a video of a type I've not reconfigured yet, and have another hard-lock 
and BRB reboot cycle.

> Amarok does not play sound. No idea why. I tried changing the Phonon
> backend from GStreamer to Xine, and get a dialog that for this change I
> will have to knotify4. What? And Amarok, but this was expected. When I
> restart Amarok, it crashes instantly. After I exchanged two entries in
> the amarokrc (I think) file, things were working again.

As I think you know, I decided amarok was going some way other than where 
I was going (due again to database issues related to its use of mysql), 
some years ago, with my switch to kde4, so I know little about that.

But, I can note that phonon-xine is masked by gentoo/kde and in the 
process of removal (if it's not gone already), due to upstream confirming 
it's dead and no further development is happening or expected.  See the 
gentoo/kde project meeting results regularly posted to the gentoo/desktop 

That leaves phonon-gstreamer, the new default for gentoo/kde and 
recommended by upstream kde/phonon, altho I've not tried it, and phonon-
vlc, which I've been quite happy with.  (FWIW I don't have gstreamer 
installed and have been reluctant to do so, due to bad experiences with 
it some years ago, altho I expect it's long past those problems now as 
they were 0.6 and 0.8 vintage, IIRC.  But so far I've had no pressing 
reason to install it, so I haven't.)

> Konqueror takes nearly a minute to display the contents of
> /usr/share/doc/digikam-2.5.0/html/. Okay, there are some 14,000 files in
> there, but it should not open as empty folder that explicitly tells in
> the status line there are '0 entries', so I first thought this folder
> was empty.

FWIW, the long response times on big directories due in part to having to 
check filetypes in ordered to display the appropriate icons in GUI file 
managers, is one of the big reasons I use mc for most file management, 
and have for years, now.  When I'm managing image or video files, I'll 
use gwenview instead, because there the larger thumbnails are quite 
useful, and I use dolphin or whatever occasionally for media files (all 
sound files, since gwenview doesn't even show sound-only files, sometimes 
video and image files as well), but otherwise, it's almost entirely mc, 
as it would have been for browsing something in /usr/share/doc/*.

With 14K of files in a dir, mc would have probably taken a bit to display 
as well, since it does have to walk the directory listing and that's 
going to take a bit with anything for a directory with 14K files, but not 
NEARLY as long as something that's reading the files as well, in ordered 
to display the proper icon.

As I said, FWIW...

> The KSnapshot save as dialog puts the cursor to the end after the 1st
> character is being entered. But at last I can finally see the snapshot
> in Gwenview, this was broken for a long time.

I'm glad they finally fixed that.  I remember confirming problems with it 
here too, when you mentioned it before.

> 20120-02-03:
> akonadi_imap_re was using 490min CPU time, this doesn't look right to
> me.

Probably due to some problem with the database...  that whole mess being 
the reason I decided it wasn't worth my trouble any longer and 
exterminated it from my system, with prejudice!

> Why does KDE keep asking me whether I want to remove a sound device?

That was quite common with phonon-xine.  I've had far less problems with 
phonon-vlc, tho with kde 4.8 or one of the 4.8 prereleases, IDR which for 
sure, I had some problems with kde saying that a device wasn't working, 
until I reordered them.  It took a bit of trial and error, but I finally 
found a stable order where the top listed device works reliably every 
time, and I don't get bothered with the fallback notifications any longer.

I noticed the problem with the fallbacks here, when I had mpd playing 
(directly to alsa) in the background, before X and kde even started.  
Based on the behavior I observed, phonon will try a device and if its 
busy or doesn't respond immediately, it falls back to another device.  My 
hardware handles stream mixing in hardware, so it shouldn't need a sound 
server or alsa's dmix, but apparently some of the virtual devices either 
don't handle mixing, or do, but with latency longer than phonon's 
timeout, so it was falling back to other virtual devices.

But what's weird is that it worked just fine for quite awhile, then all 
of a sudden, started acting up again, with kde 4.8 or one of the 4.8 
prereleases.  Whatever, I tested each device and did a reordering, and it 
works now without bugging me about fallbacks any more, even when mpd is 
already playing something, so I'm happy again.  =:^)

> Kontact hung, and I lost a long usenet posting I wanted to send later
> with KNode. Talking about KNode, like so often it shows read postings as
> new again.

You really should consider leaving knode, since it's a part of kdepim and 
thus is planned to be akonadified just as was kmail, if it hasn't been 
already.  If you don't, you'll likely have the same sort of akonadi/
database issues with it that kmail2 is now infamous for.

Of course I'm partial to pan for news, but YMMV, especially since pan 
takes a LONG time to load if you up its cache size and store years of 
group history locally, as I do.  (To get around that here, I normally 
start pan as part of my kde session, so it can spend its time loading 
while I do other things.  When I'm ready for it, it's loaded.)

Duncan - List replies preferred.   No HTML msgs.
"Every nonfree program has a lord, a master --
and if you use the program, he is your master."  Richard Stallman

More information about the kde-linux mailing list