[kde-linux] Trial and error dependencies again?? Ruby
jrtyrer at earthlink.net
Wed May 12 23:57:03 UTC 2010
On 05/11/10 22:50, Duncan wrote:
> James Tyrer posted on Tue, 11 May 2010 21:34:58 -0700 as excerpted:
>> Well, I updated Ruby to 1.9.1. There is no indication in the CMake
>> script for KDEBindings as to which version is required. However, it
>> will not build against 1.9.1 (although the CMake script shows no error).
>> So, again it appears that an older version of a dependency (1.8.x) is
>> required and there is nothing to indicate this to a user.
>> Could someone confirm that KDEBindings will not work with Ruby-1.9.x but
>> rather requires the older Ruby-1.8.x?
> It's ironic, given that you're complaining about versions not being
> specified, that you don't specify the version of kdebindings you're trying
> to build...
Sorry, I always build the current SVN BRANCH of KDE-4 (currently 4.4
showing KDE-4.4.3). However, I ask the question as a general one about
KDE-4 vs. Ruby, not about a specific version of KDE-4.
> However, for kdebindings-ruby (Gentoo splits the package) version 4.4.3, I
> can confirm that Gentoo requires the "ruby18" slot specifically, which
> corresponds to "Ruby (MRI) 1.8.x" according to the ruby-ng eclass
> manpage. But I don't know if that's a gentoo/ruby thing or upstream.
> Checking the kdebindings-ruby ebuild from the gentoo/kde overlay for
> 4.4.75 (kde 4.5 alpha, IIRC), and for 4.4.9999 (4.5 development branch
> live build) and 9999 (trunk/head), it appears they all have the same
> ruby18 requirement. 4.4.2 is still in the tree as well, but I didn't
> check it.
Since it hasn't been branched yet, the Alpha is actually just a TRUNK
I appreciate your confirmation of the problem. However, I would also
like to hear it from a developer.
Linux (mostly) From Scratch
More information about the kde-linux