[kde-linux] kppp

falkengeist at surfbest.net falkengeist at surfbest.net
Thu Jan 28 18:18:41 UTC 2010

A final, FYI post for this problem.  I could not get kppp to dial out
using my 3Com Courier 3cp3294 modem.  Since this was a top selling
modem worldwide, and had previously worked with older versions of
Linux and all versions of Windows, I thought the findings might be
worthwhile.  Also, I've seen it written many places that external
modems are the way to go when using LInux and almost always work
trouble free.

At this point I'm actually happy that I had the problem since it gave
me the opportunity to get familiar with kppp.  I found the interface
and capabilities to be exceptionally good.  The terminal program
helped me to experiment with the problem and it couldn't be more

The problem manifested itself by the modem stopping before going off
hook.  Using the log I found the initial ATZ command (a reset) was
issued successfully, then everything stopped.  I used the log on a
version of Xandros to see what was being done there since it worked
perfectly.  An ATV1 command was being issued initially without an
ATZ.  At that point I added the ATV1 to the string in kppp using the
command display and it worked.  I then replaced the ATZ with the ATV1
and it still worked.  I left this configuration and have had no
further problems.

I found that using the command display within the kppp program
applies whatever changes that you make directly to the configuration
file.  Consequently, the changes are easy and not affected by
subsequent reboots.

I hope this turns out to be helpful for other users.

Chuck Brigermann

More information about the kde-linux mailing list