[kde-linux] kppp

falkengeist at surfbest.net falkengeist at surfbest.net
Fri Jan 1 17:10:44 UTC 2010

This is a traditional, serial modem.  One of the most popular (and
expensive) in the USA when most connections were still made using
dial-up.  I have 3 of these, and they're great if you're stuck with
dial-up.  Port is ttyS0.  As I mentioned the query worked fine.

---- Original Message ----
From: kevin.krammer at gmx.at
To: kde-linux at kde.org
Subject: Re: [kde-linux] kppp
Date: Fri, 1 Jan 2010 17:46:31 +0100

>On Friday, 2010-01-01, falkengeist at surfbest.net wrote:
>> Not sure if this is the correct forum or not.  I couldn't find
>> anything specifically dealing with kppp.  If I'm in the wrong
>> please give me some direction.  If I'm in the right place, please
>> give me some help.
>> I'm currently using Xandros Linux, it's KDE/Deb for those of you
>> familiar with it.  I think it's great, and I've been using it for
>> years.  Unfortunately, I understand that it will no longer be
>> offered, and it actually hasn't been updated in 3 years.  This has
>> caused some issues with current hardware drivers, especially
>> I want to move on to something that's current and updated on a
>> regular basis.  I've tried Fedora, SUSE, Mandriva, Mepis, and
>> Kubuntu.  I have the same problem with everyone.
>> Having the same problem is not really a surprise since they all use
>> kppp.  My problem is that I can't connect using dial-up.  I'm using
>> 3Com Courier serial modem that works fine with Xandros and Windows.
>> Keep in mind that that Xandros is not current enough to have kppp.
>> I'm assuming it uses pppconfig, but has it's own network
>> configuration scheme.  The point is it works with my serial modem
>> also many Winmodems.
>> After configuring with kppp and trying to connect, CTS, RTS, MR,
>> DTN come up solid, but I never go off hook and the modem sits there
>> and we stare at each other.  The modem query works fine, and it's
>> obviously recognized OK.  I've tried numerous things without
>> and I'm out of ideas at this point.  I do want to mention that SUSE
>> has it's own, additional network setup, and after running through
>> that I did connect.  Problem there is it's cumbersome and kept
>> disconnecting also.  Mandriva is very close to Xandros, and would
>> probably be my distribution of choice if I could get the dial-up
>> working.  Their forums yielded no insight as to what the problem
>> might be.
>To which stage if KPPPs connection stage to you get?
>I am using KPPP to connect via a PCCard "mobile broadband" card and
>occasional problems with the card's specific driver which would make
>KPPP hang 
>at the "initializing modem" stage or sometimes as late as the
>"connecting to 
>network" stage.
>Is this modem of yours an externally connected one? Traditional
>serial or USB?
>Kevin Krammer, KDE developer, xdg-utils developer
>KDE user support, developer mentoring

More information about the kde-linux mailing list