[kde-linux] kppp

Kevin Krammer kevin.krammer at gmx.at
Fri Jan 1 16:46:31 UTC 2010

On Friday, 2010-01-01, falkengeist at surfbest.net wrote:
> Not sure if this is the correct forum or not.  I couldn't find
> anything specifically dealing with kppp.  If I'm in the wrong place,
> please give me some direction.  If I'm in the right place, please
> give me some help.
> I'm currently using Xandros Linux, it's KDE/Deb for those of you not
> familiar with it.  I think it's great, and I've been using it for
> years.  Unfortunately, I understand that it will no longer be
> offered, and it actually hasn't been updated in 3 years.  This has
> caused some issues with current hardware drivers, especially CD/DVD.
> I want to move on to something that's current and updated on a
> regular basis.  I've tried Fedora, SUSE, Mandriva, Mepis, and
> Kubuntu.  I have the same problem with everyone.
> Having the same problem is not really a surprise since they all use
> kppp.  My problem is that I can't connect using dial-up.  I'm using a
> 3Com Courier serial modem that works fine with Xandros and Windows.
> Keep in mind that that Xandros is not current enough to have kppp.
> I'm assuming it uses pppconfig, but has it's own network
> configuration scheme.  The point is it works with my serial modem and
> also many Winmodems.
> After configuring with kppp and trying to connect, CTS, RTS, MR, and
> DTN come up solid, but I never go off hook and the modem sits there
> and we stare at each other.  The modem query works fine, and it's
> obviously recognized OK.  I've tried numerous things without success,
> and I'm out of ideas at this point.  I do want to mention that SUSE
> has it's own, additional network setup, and after running through
> that I did connect.  Problem there is it's cumbersome and kept
> disconnecting also.  Mandriva is very close to Xandros, and would
> probably be my distribution of choice if I could get the dial-up
> working.  Their forums yielded no insight as to what the problem
> might be.

To which stage if KPPPs connection stage to you get?
I am using KPPP to connect via a PCCard "mobile broadband" card and had 
occasional problems with the card's specific driver which would make KPPP hang 
at the "initializing modem" stage or sometimes as late as the "connecting to 
network" stage.

Is this modem of yours an externally connected one? Traditional serial or USB?


Kevin Krammer, KDE developer, xdg-utils developer
KDE user support, developer mentoring
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 190 bytes
Desc: This is a digitally signed message part.
URL: <http://mail.kde.org/pipermail/kde-linux/attachments/20100101/0e72d8fb/attachment.sig>

More information about the kde-linux mailing list