[kde-linux] Fwd: NetworkManager working on Linux

James Tyrer jrtyrer at earthlink.net
Tue Apr 20 22:41:43 UTC 2010

-------- Original Message --------
Subject: NetworkManager working on Linux
Date: Tue, 20 Apr 2010 14:57:38 -0700
From: James Richard Tyrer <tyrerj at acm.org>
Reply-To: BLFS Support List <blfs-support at linuxfromscratch.org>
To: blfs-support at linuxfromscratch.org

As I mentioned elsewhere, I had an issue building it, but I now have
version 0.8 of it and the applet installed.

To work, you need to add a basic configuration file:





I note that the documentation says that this file name will be changed
in the future.

If running KDE, you also need to copy: "nm-applet.desktop" from your
GNOME autostart directory to your KDE autostart directory.

You need to setup your init.d scripts to start the NetworkManager daemon
at boot.

After doing this, you need to reboot your system (or you can go to level
1 and back).

Now, you should be able to run: "nm-connection-editor" as root.

If you have Ethernet, "Add" a "Wired" connection.  If you have a DHCP
Client installed, all you should need to do is supply the: "MAC
Address".  You can find this with the console application: "nm-tool".
Be sure to check: "Connect automatically" and "Available to all users".

Now, your Ethernet should automatically startup when you plugin the
cable as someone requested.  I don't do that, but I tried it and it
worked.  What I do need is for it to starup at boot and to restart if my
DSL connection is interrupted.

There is an issue with the applet.  The default policy means that it
will only run as root.  Some Googling and I found how to set this up so
that the applet will be on the system tray and will work for user
accounts.  These two patches [attached] based on having a: "network"
group and making the needed accounts members of it work for me.  Files
to patch are in "/etc.../dbus-1/system.d".

Note that because these are system configurations that you will need to
reboot again before the changes take effect.

I still have issues.  Stuff that should be logged is showing up on VTs.
   I will have to read more of the documentation (which is terrible or
-------------- next part --------------
A non-text attachment was scrubbed...
Name: NetworkManager_conf.patch
Type: text/x-patch
Size: 625 bytes
Desc: not available
URL: <http://mail.kde.org/pipermail/kde-linux/attachments/20100420/debc843f/attachment.bin>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: nm-applet_conf.patch
Type: text/x-patch
Size: 773 bytes
Desc: not available
URL: <http://mail.kde.org/pipermail/kde-linux/attachments/20100420/debc843f/attachment-0001.bin>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: Attached Message Part
URL: <http://mail.kde.org/pipermail/kde-linux/attachments/20100420/debc843f/attachment.ksh>

More information about the kde-linux mailing list