[kde-linux] KDE 4. Trying to get it working like I need it to.

Dale rdalek1967 at gmail.com
Mon Nov 9 14:09:01 UTC 2009

Duncan wrote:
> Kevin Krammer posted on Mon, 09 Nov 2009 13:27:38 +0100 as excerpted:
>>> In my searches, I have read similar posts about it being a version
>>> mismatch of software.  That is why I listed what I have installed.
>>> Maybe I need to install a newer version or even a older version of
>>> something.  I have the following boost packages installed:
>>> eselect-boost-0.3 (0)
>>> boost-1.37.0-r1 (1.37)
>>> boost-build-1.37.0 (1.37)
>>> Does that help show if something is a mismatch?  To new, to old?
>> In the case of the symbol mismatch you are seeing for akonadiclt, it is
>> not a question of too new or too old, but about building with a
>> different version than what you have now available.
>> Better ask on a Gentoo list, this should not happen.
> FWIW, the Gentoo command that /should/ fix this is revdep-rebuild.  Dale, 
> have you run that lately?  Personally, I run it here after every update.  
> If you haven't run it in awhile, you'll likely have quite a list of 
> packages it needs to rebuild, but if you do it after every update, it's 
> not quite so bad, particularly if you have --as-needed in your LDFLAGS. 
> (Mail me offlist if you want an explanation of the ldflags and as-needed 
> bits...  Or look it up on the Gentoo forums or ask on the Gentoo user 
> list... which I don't frequent, only the amd64 and desktop lists.)

This is my update process:

emerge -uvDNa world  < look at USE flags and such to be sure it's ok. 
bdeps is in make.conf
python-updater < if it has been updated.
emerge -p --depclean  Most of the time this is fine.
revdep-rebuild -i

I go through that until everything comes out clean. 

I also watch to see if portage tells me anything else needs to be done. 
Recently the preserved-rebuild popped up and I ran it, three times since
it kept needing to rebuild different packages.  It did eventually make
itself happy tho.

I should also mention, I have been using Gentoo since 1.4.  I don't know
it all but I been around the block a couple times.  :-) 



:-)  :-)

More information about the kde-linux mailing list