[kde-linux] knetworkmanager stopped working

Anton Moiseev benderamp at gmail.com
Mon Oct 6 11:16:12 UTC 2008


> I run opensuse 11.0  with kde 4.1.2 and NetworkManager (without the k),
> version 0.7.0.r3685-7.2-i586 in my old and only dell laptop and I have
> the same problem you have, exactly as you described. I don't remember if
> I have done the same you did (pressing and holding down the off bottom
> 10 secs), but I probably did. Maybe it is a bug. When I have a problem
> with kde and opensuse I usually wait some days or weeks until someone
> somewhere (those anonymous code heroes) fix a line of code which usually
> happens, sooner or later. Maybe we gotta let the code fixers know that
> there is this broken line down there.

I have just solved my problem - in short, the solution is to
completely remove networkmanager
plasmoid package (NetworkManager-kde4), which I have installed from
OpenSUSE factory repository.
The fact that I did not have this applet added to my desktop did not
make sense -
seems that plasma (or something else) still somehow did initialize it
and it locked
resources which knetworkmanager wanted to use.

For interest, there are more details in the discussion here:

More information about the kde-linux mailing list