[kde-linux] k3b won't verify data

Dale dalek1967 at bellsouth.net
Sun Feb 17 11:00:04 UTC 2008

Anne Wilson wrote:
> On Sunday 17 February 2008 01:18:28 david wrote:
>> Verification of burned CDs works here after telling k3b to not eject the
>> media. I also think it's HAL related. Debian Etch lenny/sid, with KDE
>> 3.5.8 and k3b 1.0.4.
> It's probably quite complex.  It has been reported on various distros, and 
> equally defended by people who use identical distro versions.  Some people 
> report the problem on burning CDs, while others say that they see it when 
> burning DVDs but not when burning CDs.  I've not seen anything that allows 
> any of the suspects to be ruled out.
> Anne
> ------------------------------------------------------------------------
> ___________________________________________________
> This message is from the kde-linux mailing list.
> Account management:  https://mail.kde.org/mailman/listinfo/kde-linux.
> Archives: http://lists.kde.org/.
> More info: http://www.kde.org/faq.html.

I decided to try to help a little on this.  I use Gentoo and since it is 
source based, I thought it may help rule in/out a couple things.  What I 
have here:




I have a LG GCE_8520B drive that is a few years old but as worked fine.  
I went to distfiles and picked just under 700MBs worth of files.  I set 
it up to burn the CD, verify the data and eject when the burn is 
complete.  It burned fine, then ejected the CD and did nothing after 
that.  After a while, I pushed the CD in myself.  It still did nothing.  
It never verified the data.  I had to cancel the remainder of the 
process.  I did get *two* pop ups on the CD tho.  It didn't used to do 
that during the verify stage.

I then went to burn with it set not to eject the media when finished.  
(I noticed that it wanted to erase the CD first.  It did, ejected the CD 
and then pulled it back in itself, no help from me this time. )  It then 
burned and verified the data with no problems at all.

This is my thoughts so far, for some reason, when K3b ejects the CD/DVD, 
it doesn't pull the CD/DVD back in so it can verify the data.  I sort of 
suspect K3b at this point.

To try to confirm this, I did the first test again with it set to eject 
when burned is finished but with data already on the CD, so it will ask 
to erase first.  BRB.  OK.  It worked like it should.  It asked to erase 
the CD first and I said OK or whatever.  It erased the CD, spit out the 
CD for just a second and then pulled it back in and started the burn 
process.  At the moment it is burning.  BRB.  OK.  It spit the drive out 
and just sat there.  Nothing after that.

My observations:  1:  K3b is not telling the drive to pull back in so it 
can verify the data.  I assume it tells hal to leave the drive alone 
while it is using the drive, lock file maybe??.  2:  I also noticed that 
when I push it back in manually, hal or something, is picking the drive 
up not once but twice.  I get *two* KDE pop-ups on what to do with the 
new media.  It didn't used to do that when verify was working.

It just seems to me that K3b is not doing it's part to pull the tray 
back in but it could be hal trying to take over the drive too.  Sort of 
seems to me that K3b is starting the problem but I'm no programmer.

I also checked the USE flags to see if maybe a option had been added but 
turned off by default.  I didn't see anything new in there.  For you 
gurus that know what this is:  [ebuild   R   ] app-cdr/k3b-1.0.4  
USE="alsa arts dvdr dvdread encode hal mp3 vorbis -css -debug -emovix 
-ffmpeg -flac -musepack -musicbrainz -sndfile -vcd -xinerama"

I guess for now, you have to tell it not to eject if you want to verify 
the data until this is sorted out.  Since Gentoo is source based, this 
should rule out a distro specific problem.  What do you folks think?  
Does these tests help any?


:-)  :-)  :-) 

More information about the kde-linux mailing list