[kde-linux] k3b won't verify data

david gnome at hawaii.rr.com
Sun Feb 10 09:49:24 UTC 2008

Anne Wilson wrote:
> On Tuesday 05 February 2008 10:51:43 david wrote:
>> Anne Wilson wrote:
>> I don't burn DVD's at all - my drive is incapable of burning a DVD. It
>> can READ a DVD, but the only thing it can burn is a CD. The drive is a
>> Toshiba DVD-ROM SD-R2512. I believe it was pretty much the standard
>> Toshiba optical drive used in all their laptops at the time.
> Sorry - I got  confused :-)  You have the problem with CDs, and Gaffer has the 
> problem with DVDs but not CDs, if I understand correctly.
>>> Sorry I can't suggest anything more helpful.  I thought of mdsums, but a
>>> burned disk would have a different sum to the original iso.  That's how
>>> k3b verifies anyway, but I think Gaffer is right, and it's not the verify
>>> that's failing, but communication.
>> I suspect it is, too. At least, k3b *thinks* it has begun the
>> verification process, it just never gets any action from the drive.
>> Possibly something in HAL, perhaps, that trips up just k3b. I haven't
>> tried Gnome's CD burning software. If it has the same problem, then I'd
>> think that would place the problem somewhere below k3b's level. If it
>> doesn't have a problem, then I'd think it's somewhere in KDE or k3b ...
>> to big an area to search.
> ISTR that you can actually see, somewhere in k3b, the command that it is about 
> to give to do the burn and verify.  Could you try pasting that command into a 
> console, to see whether it works?  That would verify whether k3b is actually 
> involved or not.  If it doesn't work at the command line either, then you are 
> both probably right - a bug in hal or similar.

I don't know where that spot might be, unless it's in the debugging log. 
But I noticed something when looking at the log. It BURNS track 1. When 
it goes to verify, though, the progress-indicating part of K3B reports 
that it's "Verifying track 0."

On a hunch, I tried another burn with K3B set to NOT eject the CD after 
burning. (Under Settings > Advanced Settings > Miscellaneous.) It 
verified with no problem. So perhaps it's some interaction between HAL 
and K3B when the disc is reinserted?

gnome at hawaii.rr.com
authenticity, honesty, community

More information about the kde-linux mailing list