[kde-linux] kmail and kdewallet

Anne Wilson cannewilson at googlemail.com
Sun Dec 28 15:50:29 UTC 2008

On Sunday 28 December 2008 15:22:47 Jim Philips wrote:
> On Sunday 28 December 2008 08:18:40 Anne Wilson wrote:
> > On Sunday 28 December 2008 12:54:39 Jim Philips wrote:
> > > I can reproduce this too. My approach is to avoid KWallet altogether,
> > > if possible. It's level of stability is such that I would only
> > > recommend it as a QA project for some aspiring tester.
> >
> > It would be nice if we could find out why a few people have this
> > experience. I've used kwallet for years and have had no problems
> > whatsoever, yet you are not the first person I've seen mention a really
> > bad experience.
> >
> > Is it worth starting a diagnostic thread, where those of you that have
> > had problems can try things suggested by the rest of us, to try to find
> > the root cause?  If we could even get any facts that would make a bug
> > report feasible it would be a great help.
> >
> > Anne
> I wasn't using KWallet at all. But because error messages from Kopete
> seemed to relate to KWallet, I tried running Kopete with Kwallet running to
> see if it would make any difference. It didn't affect the problem of not
> being able to connect to GTalk. However, it did seem to erase all account
> information for my GMail account in Kontact. That was all working before I
> ran KWallet. After Kwallet started, Kontact began to complain that "no
> host" was found for the account. I opened KMail settings to find that the
> account information for my GMail account had simply disappeared. I had to
> re-enter everything. I also found that when both KWallet and Kontact were
> set to auto-start when I logged in that Kontact would crash every time,
> apparently because KWallet had started first. At one time, KWallet worked
> for me flawlessly. I believe it started to get in the way when I switched
> to KDE 4. At any rate, I can only see it as an annoyance worthy of Windows
> Vista right now. It just forces me to constantly enter in a password, even
> though all of the passwords are saved perfectly well without it--mostly
> through Firefox.
I find it hard to believe that kwallet has erased your settings files.  I 
think you must be seeing coincidences.  As far as I know kwallet doesn't touch 
other files.

I wonder what you did to make kwallet autostart?  Normally it starts up when 
you first run an application that can use it.  If you did something to 
autostart it, maybe that's what caused the problem?  Having kwalletmgr in the 
system tray is a different thing (though in my KDE4 it doesn't obey my command 
to show in the system tray - I have to do it specifically if I want it to be 

Looking for commonalities between people that have a problem is often a good 
way of tracking down a cause.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part.
URL: <http://mail.kde.org/pipermail/kde-linux/attachments/20081228/397adf23/attachment.sig>

More information about the kde-linux mailing list