[kde-linux] cups vs lp for Epson R380 printer-SOLVED?

Paul Cartwright paul_tbot at pcartwright.com
Fri Aug 1 13:01:38 UTC 2008

On Fri August 1 2008, Paul Cartwright wrote:
> I am having a problem with my Epson R380 printer. I a running Debian Lenny,
> and the latest KDE for lenny, and CUPS.
> I installed this printer a while ago, and when you reboot, it prints for a
> while, then stops. lpstat gives me this:
> printer EpsonR380 is idle.  enabled since Fri 01 Aug 2008 08:00:27 AM EDT
> 	/usr/lib/cups/filter/rastertopips failed
> if I go to the command line and type:
> it prints to the R380 ( default printer)
> I do remember I had to really do some magic to get it to print, running
> alien on a pipslite RPM to install it... is there an easy fix for this, or
> am I trying to do the impossible??
> if I go to the web admin for printers, it shows this:
> EpsonR380 (Default Printer) "/usr/lib/cups/filter/rastertopips failed"
> 	Description: EPSON Stylus Photo R380
> Location:
> Printer Driver: EPSON Stylus Photo R380, Photo Image Print System Lite
> Printer State: idle, accepting jobs, published.
> Device URI: usb://EPSON/Stylus%20Photo%20R380

well, I went back into cups admin, and tried to FIND printers. It found 
a "new" epson USB high-speed printer. Using Firefox I tried to add it, but 
the web interface wasn't cooperating well, timed out... so I tried opera, and 
it worked. I was able to add a NEW printer:

# lpstat -t
scheduler is running
system default destination: Gutenprint_USB_Printer_1 
device for Gutenprint_USB_Printer_1: epson:/dev/usb/lp0 
Gutenprint_USB_Printer_1 accepting requests since Fri 01 Aug 2008 08:58:04 AM 
printer Gutenprint_USB_Printer_1 is idle.  enabled since Fri 01 Aug 2008 
08:58:04 AM EDT

and was able to print a test page using the web interface.
so... now it doesn't tell me my printer is an Epson R380, but it DOES print.
Paul Cartwright
Registered Linux user # 367800
Registered Ubuntu User #12459

More information about the kde-linux mailing list