[kde-linux] cannot unlock screensaver

Mark Ness mark at noneinc.us
Wed Jan 17 21:56:48 UTC 2007

Rex Dieter wrote:
> Mark Ness wrote:
>> Kevin Kempter wrote:
>>> I've recently installed FC5, ran the initial yum update and then
>>> installed the kde.repo to get the latest kde.
>>> I can login fine however once the screen saver starts, (I have it set to
>>> require passwd after 60 sec) then my password is not recognized to
>>> unlock. My only option is to start a new session and reboot.
> You are now user 2 to report this problem.  Question: did you upgrade kde
> while currently logged into kde?  (If so, I recommend not doing that).
> Regardless, post the contents of /etc/pam.d/kscreensaver and output of
> $ rpm -q kdelibs kdebase
> please (or send to me privately).
>> I am sorry to say I have no answer for you. Just a word of caution.
>> I have had MANY problems in the past mixing kde repos with fedora
>> installation of KDE. Every time I updated KDE through kde repos,
>> something broke, and the next KDE update through Fedora always
>> fixed it.
> Details?
On 3 different occasions kde-redhat updates broke my kde installation.
The first I did report here. It was broken panel and menu entries and a
kdeinit error message (something to the extent that kdeinit can start or
kdeinit not found).
I got the fix for the broken panel (don't recall what was broken but 
half the
panel options were missing). And half of my kmenu was missing including
kmenuedit and control center (though they both worked from CLI).

Someone suggested rm ~/.config/menus and run kbuildsycoca. kbuildsycoca
fixed the panel and the menu, but the kdeinit persisted until the next 

The next time I used kde-redhat, I got the kdeinit error again and it 
said it
couldn't start kde (but after clicking OK, KDE came up just fine). I 
lived with
it until the next Fedora KDE update and it fixed it. The 3rd time was 
just the
menu (lost half of the entries, but not the menueditor. kbuildsycoca did 
work this time so I edited the menu and replaced what I could remember.
Once again, the next Fedora KDE upgrade fixed it.

There have been a couple of others confirming problems with mixing the 
but did not specify their problems. It is either not that common or not 
that many
people mixing the repos.

I have not used kde-redhat since and have had no further problems.

I recently installed FC6, and was going to install KDE with kde-redhat 
of fedora, but Gnome kept crashing on me during the yum update, and I just
went ahead and groupinstalled KDE fro fedora.

Thanks for your feedback. And I doubt the problem lies with kde-redhat, 
but with
Fedoras implementation of KDE

And I hope the original poster gets taken care of.

>> I doubt there is a problem with kde-redhat repo, it just doesn't seem
>> to be compatible with Fedora implementation of KDE.
> None that I'm aware of.
> I would be much more constructive and helpful for everyone involved to
> report the problems, so we can have a chance to fix it.
> -- Rex
> ___________________________________________________
> This message is from the kde-linux mailing list.
> Account management:  https://mail.kde.org/mailman/listinfo/kde-linux.
> Archives: http://lists.kde.org/.
> More info: http://www.kde.org/faq.html.

More information about the kde-linux mailing list