[kde-linux] Starting ssh at log-in

Boyan Tabakov blade.alslayer at gmail.com
Wed Nov 22 13:21:58 UTC 2006

On 21.11.2006 21:40, Anne Wilson wrote:
> Fell at the first fence.  I can see how to edit a session, but on the
> Session tab I can only see how to save a session or remove it, not how to
> create a new one.

To create a new session, simply enter a unique name for it and press Save 
Session (then accept the proposed file name).

> I tried this method also, and the result was most unexpected.  It appeared
> to open a konsole very briefly then close it.  When I opened the console
> again it was totally transparent, but moving it moved the contents with it.
>  Copy, paste and up-arrow on the command line didn't work in it either. 
> Opening a new shell in another tab brought up a normal console.  I then
> tried the backup script and it ran without asking for the password, so I
> presume that giving the command in the Autostart script had actually done
> the job, but it hadn't requested the password.  I don't like anything
> taking total command like this.  Once I've given the password I'm happy for
> gpg-agent and keychain to manage them for my convenience, but I don't want
> it to happen without my permission.

I tried this here, and it worked just fine. However what troubles me is that 
you are not prompted for the password the second time you invoked konsole. 
This could only mean that an authentication method other than password 
authentication was used. Maybe you have copied the public ssh client key in 
your remote authorized_hosts file and forgot to remove it? Or you have your 
password stored elsewhere?

What exactly is the backup procedure? Do you open an ssh session and then 
execute a command on the remote host, or something else?

If what you really need is confirmation before you do the backup, you can do 
this in shell script and leave the authentication automated as I described, 
using the public key authentication method. For example:


echo "Are you sure? (y/n)"
read answer
case $answer in
        # your backup command goes here

        # do nothing


Blade hails you...

The 1st rock thrown again
Welcome to hell, little Saint
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://mail.kde.org/pipermail/kde-linux/attachments/20061122/19828fbd/attachment.sig>

More information about the kde-linux mailing list