[kde-linux] Kgpg problem - where to ask?

Anne Wilson cannewilson at tiscali.co.uk
Sat Mar 18 12:39:57 UTC 2006

On Saturday 18 March 2006 12:17, Grant Lewis wrote:
> On Saturday 18 March 2006 05:40, Anne Wilson wrote:
> > If there is a better place than this to ask, please direct me to it.
> >
> > I use Kontact/kmail with gpg-agent and kgpg with Fedora Core 4.  My keys
> > and .gnupg files were created some time back in Mandriva.  I copied the
> > key-rings across.
> >
> > New keys are being imported automatically, as can be demonstrated by
> >
> > /usr/bin/gpg --list-key key-ID
> >
> > However, they do not get added to the list shown in kgpg.  I tried
> > rebooting, as I was told that refresh was problematic, but it made no
> > difference.
> >
> > What could have gone wrong, and how can I fix it?
> >
> > Anne
> I'd say the easiest solution is to launch kgpg and use its import function
> from the menu, then double click the imported key and set the trust
> setting. I also had trouble with kgpg when importing my keys using gpg
> command-line tools.  Once that's done a few crypto settings in kmail are
> all that's required.
Hi, Grant.  Thanks for replying.  I'd tried that method, but it didn't work.  
However, I think I may have found the solution at last.  My latest googling 
trip came up with a suggestion to try 'gpg --rebuild-keydb-caches', and I do 
believe that the new keys are all showing now.  It went on to say that the 
command should be put into the startup file for gnupg - it was talking about 
an older version, so it may not be relevant to newer ones, but I think it's 
worth a try.  I'm going to do that now.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 191 bytes
Desc: not available
URL: <http://mail.kde.org/pipermail/kde-linux/attachments/20060318/13973fce/attachment.sig>

More information about the kde-linux mailing list