[kde-linux] trashed my ~/kde3.3/lib directory

Mark Longridge cubeman at cubezzz.homelinux.org
Fri Oct 7 07:53:05 UTC 2005

Hi Anders,

Well I solved my problem... by installing 
kde 3.4.2 with the konstruct utility! So
now I have upgraded kde with konstruct twice,
once to 3.3 and now to the 3.4.2 version.
It took about 24 hours but at least I can
now check out the latest version.

All worked smoothly but I had to do three
extra steps at the end:

chgrp -R user ~/kde3.4.2
chown -R user ~/kde3.4.2

plus I also had to:

chgrp -R user /var/tmp/kdecache-user
chown -R user /var/tmp/kdecache-user

In my case user was actually cubeman which is
what I always use. Then I rebooted and presto
it all worked. By the way I am still using 
Fedora Core 1 but that didn't seem to be
any problem. 

I don't know what a cookie file looks like
with respect to kde but I learned not to mess
with ~/kdexx.yy/lib . There are over 220 megs
of files in that directory and I don't know
what they all do so clearly I need to be more careful 
and NEVER execute "rm *". Maybe I can make
them read-only but for now I just backup that


On Thu, Oct 06, 2005 at 10:06:15AM +0200, Anders Damm wrote:
> On Wednesday 05 October 2005 15:59, Mark Longridge wrote:
> > Hi KDE-linux folks,
> >                                                                                                                              
> > I did something rather careless (typing rm * in the wrong directory)
> > and erased all the files in the ~/kde3.3/lib directory.
> >                                                                                                                              
> > Needless to say kde3.3 will not run now.
> >                                                                                                                              
> > I originally installed kde3.3 via the konstruct utility
> > and it looks like all the work files are still there.
> > Is there an easy way to regenerate these files?
> >                                                                                                                              
> > I tried "cd meta/kde;make install" like the README says
> > but it just says it's all done and it doesn't copy any
> > files to ~/kde3.3/lib .
> >                                                                                                                              
> > Thanks in advance,
> > Mark
> > ___________________________________________________
> Hi!
> If you look in the kunstruct build tree, there are some "cockie" files that indicates the status
> of the build. Removing the install cockie and run "make" will re-install the files ( if I remember ok..)
> Regards 
> Anders    

More information about the kde-linux mailing list