[kde-linux] DKE XNest Z-Axsis Problem (Post 2)

Glenn Martin lifewarped at yahoo.com
Fri Jul 15 21:17:52 UTC 2005

XNest is forwarding (X11 Forwarding) through SSH. Run on a Slackware  
Linux box.
MacOS/CYGWIN and another Slack were the tested clients.
All apps tested were run via XNest on the Slackbox using the others  
as a client.

Slackware is KDE 3.4 (What ever the slack packs are on the KDE site)

-----------------               ----------------
| SLACKWARE     | SSH/X11       | MacOS X, ETC |
|---------------| Forwarding    |--------------|
| KDE Via XNEST | <===========> | X11 Client   |
| Running KDev  |               |              |
-----------------               ----------------

On Jul 15, 2005, at 1:51 PM, Kevin Krammer wrote:

> On Friday 15 July 2005 14:47, Glenn Martin wrote:
>> currently im using SSH and X-Forwarding to Access a Slackware 10.1
>> box (KDE 3.4). I find when using Xnest ( the client could be anything
>> ive tried OS X Tiger my Main System, CYGWIN Windows, and another
>> Slack Box) Windows popup on the wrong Z-Order. For Example. On V-
>> Desktop 1 if i run KDev and want a new project the new project dialog
>> loads BEHIND KDev, if i Minimize KDev (to the Panel) and then Restore
>> it. It runs just fine. Z-Order Corrects its self, untill another
>> window is spawned. This effects any and all windows. Any idea why?
> The Xnest is the program forwarded through ssh?
> And the wrong Z-Order happens in the KDE session running inside the  
> Xnest?
> Are the applications running on the same host or are they from a third
> machine?
> Cheers,
> Kevin
> -- 
> Kevin Krammer <kevin.krammer at gmx.at>
> Qt/KDE Developer, Debian User
> Moderator: www.mrunix.de (German), www.qtforum.org

More information about the kde-linux mailing list