[kde-linux] Moving the home folder to a netware volume with KDE

Nick Chackowsky chackowsky.nick at brandonsd.mb.ca
Mon Dec 5 15:40:06 UTC 2005

I have looked at the kde-linux archives, and found some references to
configuring ICEauthority, but I don't know where to find the configuration
file. Here's my issue:

I have a lab of computers on which I have installed Slackware. 
I want to use the KDE desktop, and want to have the users' home
moved to the Novell Netware fileserver. Here's what I'm trying so far: 
I'm using runlevel 4, so the GUI auto-starts. I've set up KDE's login 
manager to auto login an ordinary account (no password) named linux. 
The home directory is therefore /home/linux. 
Once in KDE, I do the following: 
  mkdir netware 
  mkdir security 
  ncpmount -S vmserver -U "username" -P "password" netware 
  ncpmount -S vmbordermanager -U "username" -P "password" security 
  cl4others /home/linux/security/SYS 
  ln -s "netware/data/username" nhome 
That's all done in a nice Python/Tkinter script I've written, and so 
far, so good. If I do 
  cd nhome 
Then I can see all the files in my home directory on the netware 
server, and have complete rights to them. BUT, as far as Linux is 
concerned, my home directory is still /home/linux. I want it to become 
/home/linux/nhome, or /home/linux/netware/data/username. 
If, in konsole, I do export HOME="/home/linux/netware..." then the 
new HOME variable is local only to the konsole session. Any apps run 
from the desktop still use /home/linux as the home directory, which 
means of course that all the .configuration files and directories are 
in the wrong place.
In short, is there a way to somehow, once KDE is up and running, 
globally switch the user's home directory to some other location? 

I've also tried mounting the netware server BEFORE KDE starts (using 
runlevel 3). That is, I login as user linux, ncpmount the network, then 
do export HOME="new home directory" (no nice graphical system in 
this case). Again, so far, so good. BUT, I can't launch KDE. I think 
the trouble is that KDE wants to create two files called 
.DCOPserver_silver__0 and symlink  .DCOPserver_silver_:0 in the home
No trouble with the first one, but I don't think Netware will allow the 
creation of a file with a colon in it. (Just tried it 
directly-created a file called a:b and tried to copy it to the 
Netware volumne-no joy.) Perhaps there's a way to get KDE to store 
those two files elsewhere (locally) rather than in the user's home 
directory? If so, I'd be willing to forego the fancy graphical login. 
Thanks for any suggestions!


PS: This is the first time I'm using OpenText's FirstClass client to send
mail to a list; I hope it hasn't done anything weird--please let me know
if it does!

More information about the kde-linux mailing list