[kde-linux] how to troubleshoot browser - http

Robert doisneau at sonic.net
Thu Dec 1 23:20:22 UTC 2005

At 01:20 PM 12/1/2005, you wrote:
>torsdagen den 1 december 2005 20.24 skrev Robert:
>You most probably have ifup/ifdown on your computer. However, it's in
>sbin so you have to be root with root's path to use it directly. Type
>"su -" instead of "su". Another usefull program in FC is
>system-config-network where you can use a gui which might be easier.
>Check your DNS settings there.

I run /sbin/ifup eth0 and it still cannot resolve addresses in the browser: 
"Alert: www.google.com could be found.".

- My /etc/resolv.conf is properly configured and have not been changed for 
over a month.
- I did /etc/rc.d/init.d/network restart several times. Status tells me 
that eth0 is active.
- I turned off and on the dsl modem, the firewall.
- I turned off my machine.
- I logged in kde as root and as another user and tried to go to 
www.google.com using mozilla and konqueror.
- I reinstalled firefox (renaming the old directory and redoing an install).
- I can ping or do host -a www.google.com and get a result from a DNS server.

- I can see the eth0 configuration in kde window and it is the same as the 
one in /etc/sysconfig/networking/profiles/ or default/.

the other interesting thing is that another machine on my LAN has no 
problem going to internet.
I suspect that something broke in the KDE interface between configuration 
files and browsers getting the name resolution.

Is there a way to isolate the problem to a kde process.
Where does Mozilla go for resolving domain names. Is there a script, a kde 
intermediary file or does it access directly /etc/hosts and then 
What other places should I investigate?
THank you so much for your help.


>Good luck!
>Jan Simonson
>This message is from the kde-linux mailing list.
>Account management:  https://mail.kde.org/mailman/listinfo/kde-linux.
>Archives: http://lists.kde.org/.
>More info: http://www.kde.org/faq.html.

More information about the kde-linux mailing list