[kde-linux] Theme make install error

Dave Gutteridge dave at tokyocomedy.com
Sat Aug 13 03:49:25 UTC 2005

I hope this is the correct place to address this question. Please 
redirect me if it is not.

I have KDE 3.4 on CentOS (equal to Red Hat Enterprise 4).

My ambition is to simply install a theme. There are lots of themes I 
have tried installing from the "kde-look" web site. However, I encounter 
the same error with all of them.

I download the theme from the "kde-look.org" web site, and run the 
configure command, and get:
Good - your configure finished. Start make now

But then running make gets me a whole slew of errors. For example:
thinkeramik.cpp:1556: error: `KDecorationFactory' undeclared (first use 
this function)
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Those are just some of the errors that output.
Of course, I searched Google, the KDE forums, and the archives of this 
list for possible solutions. I should mention that searching the forums 
just gives a MySQL error, so if the answer is there, I couldn't access it.

What I did discover in my search for solutions was that I could down an 
RPM of the theme and install it that way. I downloaded the thinkeramik 
RPM here:

It seems to have installed okay, and I have the following files:
[root at localhost thinkeramik-3.2.1]# rpm -ql thinkeramik

But then I go to the theme manager in the Control Center, and it's not 
available in my list of themes, nor can I load it by going to any of the 
directories where the theme files are located.

So my question is simple: How do I get a theme to install?


More information about the kde-linux mailing list