Proposed terminology fixes for HDR, EDR, SDR and Bluetooth (kcm_kscreen, hdrcalibrator)
Johan Jonsson Nilsson
johan at jonssonnilsson.se
Mon Nov 2 11:39:44 GMT 2026
Hi!
I’m a Swedish user of KDE Plasma and have a few suggestions for improving the Swedish translation. I emailed the last translator, Stefan Asserhäll, a while ago but haven’t received a reply, so I’m writing here in case someone from the Swedish team can take a look, or tell me the best way to propose changes the “correct” way.
- KDE Plasma System Settings - Display - Stort dynamiskt intervall (kcm_kscreen, msgid “High Dynamic Range:”)
- From: Stort dynamiskt intervall:
- To: HDR:
- Reason: All Swedish devices and operating systems call this HDR rather than the direct Swedish translation.
- KDE Plasma System Settings - Display - Aktivera stort dynamiskt intervall (kcm_kscreen, msgid “Enable &HDR”)
- From: Aktivera stort &dynamiskt intervall
- To: Aktivera &HDR
- Reason: Same as above. The accelerator stays on the H.
- KDE Plasma System Settings - Display - other strings mentioning HDR (kcm_kscreen, hdrcalibrator)
- Includes msgid “HDR allows compatible applications to show brighter and more vivid colors.”, “Calibrate HDR Brightness…”, “HDR calibration can only be started if all settings are applied.”, “Opens a window to calibrate HDR brightness”, as well as “HDR Calibration” and the long description starting “Configure how bright “100%” ...” in hdrcalibrator.
- From: stort dynamiskt intervall / stort dynamiskt omfång
- To: HDR
- Reason: Same as above.
- KDE Plasma System Settings - Display - EDR and SDR (kcm_kscreen, msgid starting “EDR allows viewing HDR content on SDR displays ...”)
- From: Utökat dynamiskt omfång / normalt dynamiskt omfång
- To: EDR / SDR
- Reason: Same as above. EDR and SDR are the terms used in practice, and the translated terms are hard to recognise.
- KDE Plasma System Settings - Blåtand
- From: Blåtand (and blåtand)
- To: Bluetooth (and bluetooth)
- Reason: It is a technology officially called Bluetooth, so KDE Plasma should call it the same thing instead of using a directly translated term.
I also noticed that “stort dynamiskt intervall” and “stort dynamiskt omfång” are used interchangeably, sometimes within the same dialog (for example the calibration button, tooltips and the calibration window). Using HDR throughout would make it consistent everywhere. Is there a reason for the current wording, or someone I should contact directly?
I hope it’s okay that I’m writing here! Thanks in advance!
Best regards,
Johan
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-i18n-doc/attachments/20261102/5d98184b/attachment.htm>
More information about the kde-i18n-doc
mailing list