[Kde-hardware-devel] Review Request 117339: Add timeToFull/timeToEmpty, recall notice and FullyCharged to Solid::Battery
Kevin Ottens
ervin at kde.org
Thu Jul 3 06:22:08 UTC 2014
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/117339/#review61520
-----------------------------------------------------------
Note we had a major failure on this particular review as it changed some backend API but didn't adjust win or iokit backends. Those ones are likely broken since it got in.
- Kevin Ottens
On June 5, 2014, 10:24 a.m., Kai Uwe Broulik wrote:
>
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://git.reviewboard.kde.org/r/117339/
> -----------------------------------------------------------
>
> (Updated June 5, 2014, 10:24 a.m.)
>
>
> Review request for Solid and Àlex Fiestas.
>
>
> Repository: solid
>
>
> Description
> -------
>
> This adds the following functionality to Solid::Battery:
>
> - timeToFull and timeToEmpty (at the moment provided by PowerDevil but for all batteries combined, this patch does it individually for each)
> - rename isPlugged to isPresent (as plugged always confused me - it has nothing to do with whether AC is plugged in but if the battery is "present in its bay", it's also the name of the UPower iface)
> - FullyCharged battery state, we cannot rely on the battery being 100%, and since the info is provided by UPower (not on HAL), why not use it
> - RecallVendor/RecallUrl when a battery has been recalled by the vendor, currently provided/handled by PowerDevil
> - Serial number of the battery
>
> Sorry for the hard to read patch but I also re-ordered some methods to have the order in all implementations and headers the same.
>
>
> Diffs
> -----
>
> src/solid/devices/ifaces/battery.h 79e0d60
> src/solid/devices/frontend/battery.cpp e433582
> src/solid/devices/frontend/battery.h bbf2201
> src/solid/devices/backends/upower/upowerbattery.cpp c771f68
> src/solid/devices/backends/upower/upowerbattery.h 9b49d32
> src/solid/devices/backends/hal/halbattery.cpp a2ac83d
> src/solid/devices/backends/hal/halbattery.h 1e60aeb
> src/solid/devices/backends/fakehw/fakebattery.cpp 9af4c6c
> src/solid/devices/backends/fakehw/fakebattery.h fdb4bcc
>
> Diff: https://git.reviewboard.kde.org/r/117339/diff/
>
>
> Testing
> -------
>
> Compiles, solid-hardware5 details /org/freedesktop/UPower/devices/battery_BAT0 reports:
>
> udi = '/org/freedesktop/UPower/devices/battery_BAT0'
> parent = '/org/freedesktop/UPower' (string)
> vendor = 'ASUSTeK' (string)
> product = 'UX31-35' (string)
> description = 'Lithium Ion Battery' (string)
> Battery.present = true (bool)
> Battery.type = 'PrimaryBattery' (0x3) (enum)
> Battery.chargePercent = 31 (0x1f) (int)
> Battery.capacity = 83 (0x53) (int)
> Battery.rechargeable = true (bool)
> Battery.powerSupply = true (bool)
> Battery.chargeState = 'Discharging' (0x2) (enum)
> Battery.timeToEmpty = 5105 (0x13f1) (qlonglong)
> Battery.timeToFull = 0 (0x0) (qlonglong)
> Battery.energy = '13.223' (string) ? dunno why it says string, it's double everywhere
> Battery.energyRate = '9.324' (string) ? same
> Battery.voltage = '7.4' (string) ? same
> Battery.recalled = false (bool)
> Battery.recallVendor = '' (string)
> Battery.recallUrl = '' (string)
> Battery.serial = '' (string)
>
>
> Thanks,
>
> Kai Uwe Broulik
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-hardware-devel/attachments/20140703/161e98cd/attachment.html>
More information about the Kde-hardware-devel
mailing list