[kde-freebsd] [kde5] help installing (#1)

Sébastien Mainand sebastienmainand at gmail.com
Thu May 28 07:28:26 UTC 2015

I compiled it on both my laptop and desktop pc and it worked! I just had
the following error (both times):

===>  License GPLv2 accepted by the user
===>  Found saved configuration for libgit2-0.22.1
===>   libgit2-0.22.1 depends on file: /usr/local/sbin/pkg - found
=> libgit2-libgit2-0.22.1-v0.22.1_GH0.tar.gz is not in
=> Either /usr/ports/devel/libgit2/distinfo is out of date, or
=> libgit2-libgit2-0.22.1-v0.22.1_GH0.tar.gz is spelled incorrectly.
*** Error code 1
make[1]: stopped in /usr/ports/devel/libgit2
*** Error code 1
that I passed by installing libgit2 with pkg (# pkg install libgit2)

Where can I find the kde5-applications ? I couldn't find a
"plasma5-baseapps"-like port.

Out of curiosity, what is the difference between all the plasma5-plasma*
ports ?

Thanks for your help

2015-05-26 21:11 GMT+02:00 Tobias Berner <notifications at github.com>:

> At the moment my github repo is a bit behind -- the plasma5 branch of
> area51 contains the current version. So I'll describe how to use that one :)
> 1) Clone the plasma5 branch of area51 to a directory of your chosing
> # svn co http://area51.pcbsd.org/branches/plasma5
> 2) Run kdemerge -a on it
> # plasma5/Tools/scripts/kdemerge -a /usr/ports
> 3) Edit /usr/ports/Mk/bsd.port.mk using the following command / by hand
> # sed -i .bak_kde\
> -e '/defined(USE_KDE4)/ s#$# || defined(USE_KDE5)#g'\
> -e '/defined(KDE4_BUILDENV)/ s#$# || defined(KDE5_BUILDENV)#g'\
> -e 's#bsd.kde4.mk#bsd.kde.mk#g <http://bsd.kde4.mk#bsd.kde.mk%23g>'\
> /usr/ports/Mk/bsd.port.mk
> [This should wire in the new KDE-bits, i.e. bsd.kde.mk should get sucked
> in
> instead of the old bsd.kde4.mk if either USE_KDE4 or USE_KDE5 is set].
> 4) Deinstall kde4 (this will give your build greater chances to succeed :)
> )
> # pkg delete kde* attica*
> [This step might be a bit annoying. You may get around it, by updating
> kdelibs4 and attica after you merged the plasma5 ports.
> The problem is that there are header files that share the same name, and
> lead to compile errors, when the wrong one is picked up. In the
> plasma5-branch version of the ports, they do get installed into
> ${LOCALBASE}/include/kde4 instead of ${LOCALBASE}/include which
> fixes that issue. So you may get around by simply issuing
> # portmaster kdelibs attica
> # portmaster -o x11-themes/kde-icons-oxygen x11-themes/kde4-icons-oxygen
> # portmaster
> Though I have never tried whether this works.
> -- I would recommend a fresh start.]
> 5) Install x11/plasma5-plasma
> # cd /usr/ports/x11/plasma5-plasma && make install clean
> An important note: Make sure, you have both DOCS and NLS enabled. Some
> of the ports will not build if either is not set (sorry -- I added
> them too soon).
> If all goes well you should now have plasma5 \o/.
> Simply start it using "startkde" in .xinitrc with something like:
> exec startkde > ~/startkde-date +"%Y-%m-%d_%H-%M-%S" 2>&1
> You should also be able to build (most) of the kde-applications 15.04
> release.
> Simply run portmaster/make on them as you see fit.
> Note: There are most likely some conflicts/breakages I didn't notice here
> (i.e. forgot to merge something). So I would be glad if you could send me
> the fallouts :) (e.g. kdepim at the moment is broken in plasma5-branch as
> there is a conflict between akonadi and kf5-akonadi, which I have to fix).
> mfg Tobias
>> Reply to this email directly or view it on GitHub
> <https://github.com/tcberner/kde5/issues/1#issuecomment-105637697>.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-freebsd/attachments/20150528/967d2f51/attachment.html>

More information about the kde-freebsd mailing list