[kde-freebsd] Re: [CFT] KDE SC 4.6.0 for FreeBSD.

Hannes list_kde-freebsd at soulrebel.in-berlin.de
Tue Feb 1 12:53:12 CET 2011

Zitat von "Raphael Kubo da Costa" <kubito at gmail.com>:

> Hannes <list_kde-freebsd at soulrebel.in-berlin.de> writes:
>> I did a pkg_delete -a, reinstalled xorg and qt4 from packages and then
>> built most of kde by "make install clean".
>> Issues:
>> - kdebase4-workspace and nepomukcontroller are not make_jobs_safe
>> although they claim to be
> This is weird -- I compile everything from trunk (ie I don't use the KDE
> ports), and I'm always able to compile each module with gmake -j3 here.

I have 4 Cores here,  but I am not 100% sure its related to jobs,  
maybe its some other weirdness.
It just failed building, what I always do in these cases is deactivate  
MAKE_JOBS_SAFE and the make build again which worked in these cases?

>> - kdepim4 wants libassuan.1, but the port only provides .0 (manually
>> changing the Makefile solved this)
> Maybe the port is wrong? I can run kdepim just fine with libassuan.0.

Yep thats what I meant. I changed the port and didn't run into issues  
(although I can't say for sure, since kmail obivously doesnt run on my  

>> ** RUN STAGE**
>> Most things seem to work pretty well, only issue so far is that I
>> can't make kmail run. It starts the kmail migration wizard thingee,
>> which successfully migrates all my ressources. When I click Ok the
>> migration wizard dissappears, but Kmail doesn't open. ps ax shows both
>> kmail and the migration tool running invisible in the background. I
>> tried killing both and starting again, but to no avail. The migration
>> manager opens again, tells me that everything is already migrated and
>> that i am ready to go...
>> I do not want to reset my settings since I have lots of complicated
>> filters set up and my aggregation and list view are heavily
>> customized...
>> Oh and all the apps give me:
>> kmail-migrator(31594)/kdeui (KIconLoader): Unable to find an
>> appropriate lock to guard the shared cache.  This *should* be
>> essentially impossible. :(
>> kmail-migrator(31594)/kdeui (KIconLoader): Unable to perform initial
>> setup, this system probably does not really support process-shared
>> pthreads or semaphores, even though it claims otherwise

The KIconLoader stuff is not related to PIM, it happens with all the  
software really.

> Hmm, I hope when 4.6.x migrates to the ports tree kdepim remains at the
> 4.4.x series until a stable release is made, otherwise we will have
> problems.

Hm, I think its really bad that kdepim hasn't had updates in a year,  
since it is core functionality of KDE SC and it does have serious  
issues that need to be adressed.

> Can you compile at least the pim-related ports with WITH_DEBUG=1, check
> if you need to enable some debug information with 'kdebugdialog' and
> then run this again? You should get some more useful output.

I will try that tomorrow. What is "pim-related" other than kdepim and  

> After that, I recommend filing bug reports on bugs.kde.org -- kdepim 4.6
> is still under development, and some time ago the developers said they
> needed more migration reports.

I will do that next, although in general my experience when reporting  
bugs upstream is that everyone says they are FreeBSD-related and  
therefore noone volunteers to fix them :S

Thanks for your help,

More information about the kde-freebsd mailing list